PDA

View Full Version : [ubuntu] Default sound device



ghostofmybrain
August 25th, 2009, 11:44 PM
I'm having trouble figuring out how to set my default sound device. It seems like about half my sounds come through my speakers and the other half through my USB headset. For example, Rythmbox and system sounds come through the speakers, but Amarok and firefox come through the headset. I went to System/Preferences/Sound and changed all the output to the HDA Intel ALC1200 Analog (OSS), which when I push the "test" button gives me sound through the speakers. But still, about half the programs will make sound through the headset, which I don't want.

Um... I'm using Jaunty... I'm also very very new to linux, so I don't know what other information you need to help me out. :P

lian1238
August 26th, 2009, 12:37 AM
Do you have the option "ALSA - Advanced Linux Sound Architecture"? Try that.

ghostofmybrain
August 26th, 2009, 02:08 AM
Do you have the option "ALSA - Advanced Linux Sound Architecture"? Try that.
Yes, I do. I tried that first, but when I click "test" I get no sound whatsoever.

krul
August 26th, 2009, 01:55 PM
install padevchooser...this is a system tray application where you can specify for each program/source on which sound card it should play...works like a charm

ghostofmybrain
August 26th, 2009, 05:36 PM
install padevchooser...this is a system tray application where you can specify for each program/source on which sound card it should play...works like a charm
I can't figure out where in that program I can specify for each program which sound card it should play on.

Also, is there anything specific my settings need to be in "sound" for this to work?

ghostofmybrain
August 26th, 2009, 06:15 PM
I can't figure out where in that program I can specify for each program which sound card it should play on.

Also, is there anything specific my settings need to be in "sound" for this to work?
Aha! I figured it out reading the Jaunty 9.04 Sound Solutions thread (http://ubuntuforums.org/showthread.php?t=1130384). Yay. I will celebrate with my favourite food. :popcorn: