PDA

View Full Version : [kubuntu] Enabling Desktop effects crashes desktop



landonstein
August 24th, 2009, 02:44 PM
Hey everyone.

Basically I'm a newbie to kubuntu and since installing it, I have had a pretty fun time playing around with it, but there is one thing that has been annoying me a bit and that is that everytime I try to enable desktop effects of any kind in the System Settings, my screen will go black and then it will flash pieces of the desktop every few seconds.

So far I've tried reinstalling my ati Radeon hd 4850 video cards drivers both manually and by using the hardware drivers install utility. I have tried changing each of the settings under the general and advanced tabs of Desktop Effects and numerous other fixes that people have listed online but none of them have worked.

I have also tried changing the Compositing type to XRender but when I try that I get an error saying 'Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.'

I've looked all over the internet for a solution for my problem but none of them have worked so if anyone could please give me some possible solutions I'd be very thankful.

krazyd
August 25th, 2009, 02:47 AM
I've got the same card, and I've decided to wait until kubuntu 9.10, when 3D should work on the open source drivers (developers recently got compiz working).

I did have fglrx working with Desktop Effects on kubuntu 9.04 (installed straight from the repository), but it was unstable and buggy and not really worth it.

With the open source drivers (which are loaded by default in 9.04) I get 2D acceleration, Xv video acceleration etc.

landonstein
August 25th, 2009, 06:54 AM
Ah thank you so much for the reply, now that I know that it's a hardware issue that should be fixed in 9.10 I'll rest a bit easier.

I did manage to get some of the desktop effects enabled today for a short while but as you say it was buggy and definitely not worth the hassle.