PDA

View Full Version : [SOLVED] 8.04 Hardy & Radeon HD4850 problems w/ Desktop Display after Synaptic update



Hsere
August 23rd, 2009, 07:42 PM
I originally posted this in "General Help." Sorry about the repost, but it's been about a month and no one seems to know what the problem might be, so I'm trying my luck here.

System Info:
Version: Hardy 8.04, Kernel 2.6.24-19 Generic, booting with all_generic_ide
Hardware: ASUS P5Q mobo, Intel Dual Core 3.0 GHz CPU, 2.0 GiB RAM, ATI Radeon HD4850 Video Card running restricted "fglrx" drivers, HP w1907 1440x900 LCD Monitor.

I had previously had problems getting my video card to function properly with Ubuntu 8.04, particularly with my wide-screen monitor. With help from these forums, I managed to resolve the issue. Original thread here (http://ubuntuforums.org/showthread.php?t=1024465).

Synaptic's updates seemed to undo my fix, but I managed to solve that by just reinstalling the ATI fglrx drivers from their website. Original thread here (http://ubuntuforums.org/showthread.php?t=1037650).

This occurred for subsequent Synaptic updates, and I could generally fix the problem by reinstalling the drivers again. However, after I ran Synaptic's Update today and did the above-described actions, the windows in ubuntu move with a lot of lag and tearing, and scrolling is similarly slow. I also can't enable desktop effects (it gives me the good old "desktop effects could not be enabled" message when I try).

I hadn't run Synaptic Update for several months, so I'm not sure what exactly caused this problem (yes, I know, I'm bad. *Smacks self on wrist*).

Any help anyone can give would be appreciated. Here's my xorg file, in case it helps:



cat /etc/X11/xorg.conf
Section "ServerLayout"
Identifier "Default Layout"
screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "EnableMonitor" "crt1,lvds,tv,tmds1,crt2,tmds2,cv,tmds2i"
Busid "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
Defaultdepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

markbuntu
August 23rd, 2009, 11:15 PM
The most likely cause of your problem is that a kernel update did not build the fglrx kernel modules so you have no DRI2 and no hardware acceleration. The reason for this is usually because you have more than one set of driver kernel modules in your system and so the kernel cannot decide which one to build so it leaves that up to you to do manually.

The reason for this is usually because an old driver was not removed before installing a new one and so have more than one set of kernel modules lying about. To fix this permanently you can purge/remove fglrx and the fglrx kernel modules then reinstall just one driver, the latest would probably be a good idea.

Once you do that you will no longer have issues with kernel updates.

If you ever upgrade to Intrepid or Jaunty of Koala remember to remove fglrx before doing so to avoid problems.

Hsere
August 24th, 2009, 07:00 AM
Thanks a lot, markbuntu. How would one go about removing fglrx and the fglrx kernel modules? I uninstalled the old driver version before upgrading to the new one, as per the instructions on p. 3 of the .pdf instructions from ATI, but I'm still getting the problem, so I assume I have to do something else.

I appreciate the response.

markbuntu
August 24th, 2009, 09:08 PM
If you installed an even older version with hardware manager or Envy, you need to remove them also which you can do with Synaptic or Envy respectively.

To get rid of all of fglrx you can

sudo apt-get purge fglrx* fglrx-kerrnel-source

or something like that, maybe fglrx-kernel-module..

It has been a long time since I had to remove fglrx by hand and I really do not remember exactly how I did it.

Hsere
August 25th, 2009, 01:01 AM
I removed all the fglrx packages I could find in Synaptic, ran the commands markbuntu suggested, and uninstalled the drivers via ATI's instructions (the .PDF is here (http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.36&lang=English), above the download link). I then reinstalled the drivers from ATI's website via their instructions (the same .PDF) again. I then checked on the installation log file in /usr/share/ati:


/usr/share/ati$ cat fglrx-install.log
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : No kernel module build environment - please consult readme.


Looks like I haven't managed to get rid of the old kernel modules (unless something else is going on). This may not actually mean anything or be helpful, but I also ran
locate fglrx and it looks like I came up with a lot of filenames referencing past kernel versions (e.g., 2.6.24-19-generic). Still trying to get this problem solved. Any other insights from anyone?

Hsere
August 27th, 2009, 03:30 AM
Fixed. Apparently, my system had a bug in which menu.lst wasn't being updated, even by update-grub (I searched and apparently a few people here have experienced it). The drivers were designed for version 2.6.24-24, and I was running 2.6.24-19, hence the inability to update properly. I purged and reinstalled update-grub, upgraded to 2.6.24-24, and uninstalled/reinstalled the drivers, and they seem to be working now (apart from some tearing, but I think that's just an issue with my screen). Huzzah. I am, however, getting the following message when I try to run aticonfig:



~$ /usr/bin/aticonfig --initial
Found fglrx primary device section
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-7
/usr/bin/aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.


Despite this, my xorg.conf seems to account for the drivers:


~$ cat /etc/X11/xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Many thanks to all who posted with advice/ideas.

Marking as "solved."

EDIT: Hrrrmm. Can't mark it as "solved" for some reason. It's supposed to be under "Thread Tools," right?

EDIT 9-5-09: The "Mark Solved" button has returned.