PDA

View Full Version : [ubuntu] 9.04 freezes during boot



SigMtnDawg
August 13th, 2009, 01:35 AM
This got zero response under general help, so I'll try the noobie area. After all, some may call this a noobie question.

9.04 freezes during boot
I'm a bit of a noob, so please forgive any noobieness to this post. However, I did search quite a bit before starting a new post.

Here's my problem. Occasionally (so not every time), Ubuntu freezes during boot. In order to get it moving again, I can push 'Enter' or one of the arrow buttons. Unfortunately, I have to do this many times or it just sits there. Also, I can't just hit one of those buttons each time if freezes, because it doesn't always work. In other words, I sometimes have to wait a few seconds and hit the buttons again.

Before this started, I had a nice startup time of about 65-70 seconds. Now, it may take 2-3 minutes. Speed is not my biggest concern here, but I would like to have my zippy machine back on a consistent basis. My biggest concern is some possibly bigger looming problem with who knows what, but I have run diagnostics on the hardware, and nothing appears to be wrong.

Thanks in advance for the help.

zeroseven0183
August 13th, 2009, 01:39 AM
Hi! It would be helpful also if you could post the hardware specs of your computer.

In your System Monitor (System > Administration), what process takes up a lot of CPU usage?

SigMtnDawg
August 13th, 2009, 03:41 AM
OK, system is an HP with AMD Turion & 3 GB of ram & 150 GB hard drive. The Ubuntu version is 9.04, Kernel Linux 2.6.28-14-generic, GNOME 2.26.1.

The gnome-system-monitor takes up about 10-15% and firefox takes up about 2-3%, but I don't think that matters. The real issue is that often (about 65% of the time now) when I start up the system, it hangs up at the Ubuntu splash screen. I suppose it would finally get going on its own, but my impatience has led me to figure out that pressing 'Enter' or the arrow buttons sort-of kick starts it into continuing. Once the system gets booted up, it seems to work OK. I'm just worried that there's something worse going on.

How do I fix this, and should I be concerned?

Thanks

xPr0star
August 13th, 2009, 03:51 AM
Disable splash try to see where it's hanging open up terminal and type
sudo gedit /boot/grub/menu.lst remove quiet and splash entries

LewRockwell
August 13th, 2009, 04:00 AM
see if you can get a verbose start-up report and/or log

if you watch the verbose you might see what's hanging

http://ubuntuforums.org/showthread.php?t=1108364

.

SigMtnDawg
August 13th, 2009, 10:13 PM
OK, how do I get a verbose startup report/log? I see many logs under System Log Viewer, but I don't know which one to use.

Thanks

cookiedemkp
August 14th, 2009, 09:53 AM
Hey try this, go and

sudo gedit /boot/grub/menu.lstand where it shows your kernel at the very bottom, the line should look similar to

kernel /boot/vmlinuz-2.6.27-14-generic root=UUID=1886BA2586BA0374 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio quiet splashadd this line onto the very end of that line:

acpi=noirqso it will finally look like this:

kernel /boot/vmlinuz-2.6.27-14-generic root=UUID=1886BA2586BA0374 loop=/ubuntu/disks/root.disk ro ROOTFLAGS=syncio quiet splash acpi=noirqThat should stop you from having to hold a button. Call me a liar if that doesnt work.