PDA

View Full Version : problema con tarjeta grafica nvidia quadro2 pro [NC15GL]



_ZeTa
August 10th, 2009, 07:16 PM
muy buenas!
El problema que tengo, básicamente es que estoy instalando una targeta nvidia quadro2 pro [NC15GL], que se supone está dentro de los drivers legacy que provee nvidia. Pero cuando intento instalarlo me sale que está obsoleto...
lo que hice fue:
Bajar el driver directamente de nvidia.com
en el apartado legacy. [NVIDIA-Linux-x86-71.86.11-pkg1.run]
lo ejecuté en tty1 [sin el servidor gráfico]
listo, instalado. Luego lo agregue dentro del xorg.conf [previo backup], y chadan!!! problema en graficas... corro en modo low-grafics, y veo el log de xorg.0.log y me sale lo siguiente cuando carga el driver de nvidia:


(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load modile "nvidia" (loader failed, 7)
(EE) No drivers avaliable.

Fatal server error:
no screens found

bla bla bla...

modifiqué el xorg.conf siguiendo el archivo leeme de nvidia, que decía que debía modificar lo siguiente:


Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the "Module" section of the file, add the line (if it does not already
exist):

Load "glx"

If the X config file does not have a "Module" section, you can safely skip the
last step if the X server installed on your system is an X.Org X server or an
XFree86 X release version 4.4.0 or greater. If you are using an older XFree86
X server, add the following to your X config file:

Section "Module"
Load "extmod"
Load "dbe"
Load "type1"
Load "freetype"
Load "glx"
EndSection

ahora... lo que deja como cachuo es que tengo los drivers dentro de los modulos pero el archivo no aparece con dos // sino con una

/usr/lib/xorg/modules/drivers//nvidia_drv.so

no debería decir:

/usr/lib/xorg/modules/drivers/nvidia_drv.so

????

si es asi, como puedo modificar la referencia a ese archivo??

saludos!!!!

kamus
August 11th, 2009, 07:23 PM
esta cargado el modulo nvidia? podrias postear tu xorg.conf?, porque no instalas el controlador desde Sistema->Controladores de Hardware? asi te evitas todo el jaleo y manoseo de archivos conflictivos ;)

Saludos

_ZeTa
August 11th, 2009, 10:01 PM
claro, desde los controladores de hardware sería mas sencillo, el problema es que no aparece ningún driver dentro de aquel apartado...

mi xorg.conf


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

saludos!