View Full Version : [ubuntu] Intel Corporation PRO/Wireless 2200BG

August 10th, 2009, 06:59 PM
Hi I got a dell latitude d610 laptop and well its got the good ol, Intel Corporation PRO/Wireless 2200BG wireless card and blue tooth and well after 2 days of surfing the forums and 2 fresh installs later still nothing!
I ran nm-tools and got the following:

Device: eth0 [Auto eth0] ----------------------------------------------------
Type: Wired
Driver: tg3
State: connected
Default: yes
HW Address: 00:00:00:00:00:00

Carrier Detect: yes
Speed: 100 Mb/s

Wired Properties
Carrier: on

IPv4 Settings:
Prefix: 24 (


- Device: eth1 -----------------------------------------------------------------
Type: 802.11 WiFi
Driver: ipw2200
State: disconnected
Default: no
HW Address: 00:00:00:00:00:00


Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points

*And that's that I am wanting to use this thing as a door stop but I have such great success installing it on other computers. What to do and help is greatly appreciated!

August 10th, 2009, 07:38 PM
Driver: ipw2200
State: disconnectedI wonder if that means the wireless switch or key combination is switched off. If you manipulate the switch, does the LED turn on and off or flicker? Please open a terminal and do:
sudo cat /var/log/messages | grep -i rfkillAny clues?

August 10th, 2009, 08:37 PM
I ran that in terminal and nothing happened at all. It knows the card is there but the wireless and the blue tooth are "out to lunch" for some reason. The most frustrating thing is that this is a old laptop so you would think that their would be some sort of fix! Again any help is greatly appreciated. Any more ideas please and thank you - thanks Chilli

August 11th, 2009, 02:45 PM
Did you check to be sure that wireless and bluetooth are both enabled in the BIOS. In my laptop, if the bluetooth is disabled in the BIOS, the wireless doesn't work. Also, please try:
sudo rmmod -f ipw2200
sudo modprobe ipw2200 bt_coexist=1If that does it, we will need to take additional steps to make it permanent. Also, please post:
dmesg | grep 2200Thanks.