PDA

View Full Version : [ubuntu] how do i install farsight2



jarrah-95
August 10th, 2009, 06:30 AM
when i try to install farsight2 for amsn the ./configure fails and the end of the output says


checking for PYFARSIGHT... configure: error: Package requirements ( pygobject-2.0 >= 2.12.0
gst-python-0.10 >= 0.10.10 ) were not met:

No package 'pygobject-2.0' found
Package pygtk-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pygtk-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pygtk-2.0', required by 'gst-python', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PYFARSIGHT_CFLAGS
and PYFARSIGHT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

jarrah@jarrah-laptop:~/farsight2-0.0.12$ sudo apt-get install pygobject-2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package pygobject-2.0
jarrah@jarrah-laptop:~/farsight2-0.0.12$ sudo apt-get install pygobject
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package pygobject
jarrah@jarrah-laptop:~/farsight2-0.0.12$ sudo apt-get install pygobject-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package pygobject-dev
jarrah@jarrah-laptop:~/farsight2-0.0.12$

how do i fix this to get farsight to work also if it is a package that i need what is the name
thanks

jarrah-95
August 10th, 2009, 10:36 AM
i have installed some of the needed packages but the rest i cant find.
this is where im up to now


Requested 'pygobject-2.0 >= 2.12.0' but version of PyGObject is 2.6.0
Package pygtk-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pygtk-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pygtk-2.0', required by 'gst-python', not found

what packages do i need to install
thanks

kevdog
August 10th, 2009, 12:07 PM
Did you try searching for it in the archives:

sudo apt-cache search pygobject

jarrah-95
August 11th, 2009, 08:53 AM
no but i did try apt-get and and i also serched synaptic and i have installed everything that came up that looked right

Moustaffa
November 29th, 2009, 10:49 PM
I have the exact same problem, isn't there anyone who could help solve this problem? It would be much appreciated

Claus7
November 30th, 2009, 11:31 AM
Hello,

there is a long time since I was facing problems about the installation of farsight in Dapper. For the pygobject thing, I think that the pygtk-2.12.1.tar.gz might do the trick, yet I do not remember for sure. There have been years since then...

http://ubuntuforums.org/showpost.php?p=4871922&postcount=4

Even though I would not like to say such things, I would not advice you to try such procedure in versions less than karmic. If you do try to make the compilation of farsight and afterwards to make it work with amsn, I would most like to see this effort. Have in mind that in karmic is already compiled for you, even if it is not working as it should at the moment.

Regards!

Hilko
December 1st, 2009, 11:18 PM
Same problem here. I really hate to reboot in windows to talk to people on windows live messenger.
I really really hope someone can help and give instructions to get farsight2 installed for amsn. It will be very very very much appreciated.

Hilko
December 2nd, 2009, 12:06 AM
Ok i've found this in some (i think) spanish post

http://ubuntuforums.org/showthread.php?t=1321171

Hola, yo uso karmic y para instalar el amsn 0.98 lo que tuve que hacer es desinstalar el que tenia ( busque en synaptic todo lo que fuera amsn y lo desinstale completamente, eliminando toda configuración guardada), luego agregue este repositorio:
deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu karmic main
actualice (sudo apt-get update) y luego instale ( sudo apt-get install amsn) aceptando todos los paquetes sugeridos y listo,
espero te sirva

Having no idea what is says i just tried this
-completely remove the packages amsn and amsn-data.
-add
deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu karmic main to your software sources.
-reload all the packages.
-install amsn and amsn-plugins-extra
I ignored all the warnings about the authentication of the new repository. If you wanna do this is up to you.

It seems promising. I have not actually made a voice or video call yet, but when i started amsn and went into the preferences it said farsight2 was installed and everything looked ok.
I hope it really works.

swissz
January 9th, 2010, 01:25 PM
Hi Hilko!
And how is it? Is it working now?
Regards!

Hilko
January 10th, 2010, 05:29 PM
It does not work like i hoped it would. I have not been able to make a video cal. Audio call worked kind of, but far from perfect. The sound stream was interrupted frequently with blocks of silence. I was able to hear someone at the other end and that one could hear me.
However, i still need to reboot in windows to make a call.

Maybe it can be improved if i configure my devices differently ? I don't know. Has anyone had better results ?

shadchelaka
March 23rd, 2010, 06:57 PM
i tried what you did hilko and as you said everything worked out. i can now use amsn 0.98.3. thankx for that

nway i went to preferences n tried to configure my audio/video settings.
once i've done everything this came out:

"Audio/Video call capabilities have been disabled in this version of amsn because M$oft has changed their protocols again and disabled access to their SIP servers, blocking amsn from giving you access to this feature."

hope this helps. cheers.

fonsi2099
November 2nd, 2010, 10:34 PM
:guitar: the same problem for me, thank you for any help!