PDA

View Full Version : [ubuntu] ath9k injection 2.6.28-14



chaosdesigner
August 8th, 2009, 04:26 PM
Hey guys,

Im currently playing a little around with aircrack and its other tools but i have come to a problem. I pretty much completly followed this 'How-To': http://ubuntuforums.org/showthread.php?t=528276. My only problem is now that i need to patch my wireless driver so that injection can work. If read alot about this injection and im still a little confused, even though the aircrack-ng wiki very helpfull and very explainatory is.

I have a Atheros Chipset and the newest madwifi driver, ath9k. In the artictle on the aircrack-ng wiki page about the ath9k it said that my kernel, the 2.6.28-14 (im using jaunty btw) should support injection. I unfortunatly still, even after reading me through all those articles, dont know which patch i should download here: http://patches.aircrack-ng.org/.

Can anyone tell me how to patch the ath9k with my kernel? Should i consider using a diffrent driver?

Thank you alot :)

firen
August 8th, 2009, 06:24 PM
Try Knoppix STD http://www.knoppix-std.org/ its a Live CD Security tools distribution, if it works then maybe you don't need to patch.