PDA

View Full Version : [ubuntu] ATI Drivers from Ati.Amd (want to progress from newbie status)



walkerx
August 5th, 2009, 02:07 PM
I've downloaded and installed the Ati Catalyst 9.7 drivers directly from Ati/Amd's website.

I followed their instructions by uninstalling previous drivers, etc and then rebooted and dropped to shell (root with network support).

I installed the drivers but during install they stated i was using glibc 2.1 but on the readme for the drivers it states need 2.2 or 2.3, yet everything seems to be working.

Next under compiz-check it picks up the driver but reports no renderer, but all the fancy desktop extras are working.

Should I need to upgrade glibc 2.1 to 2.2/3 and if so how easy is it to do, as can't find the info in synaptic.

Also should I modify xorg.conf to include XGL or again should I not worry as everything seems to be working, even running glxgears shows very good frame rates which would suggest everything is installed correctly.

Or should I remove the 9.7 drivers and use the ones from the restricted repository?

I'm running ubuntu 9.04 64bit with an ATI 4870x2 2gb (R700)

thanks in advance