PDA

View Full Version : [ubuntu] Remote Desktop Viewer



dunbrokin
August 2nd, 2009, 10:34 AM
I am trying to reset up my Remote Desktop Viewer......but I keep getting this message when I try to access the second PC.

Connection to host pj-weather.local:5900 was closed.

The port is closed automatically it would seem....how do I reopen it and keep it open?

hellmet
August 2nd, 2009, 11:23 AM
You might have to open up a port on the firewall on the second PC and/or enable Remote Desktop

dunbrokin
August 2nd, 2009, 11:52 AM
Remote desktop is enabled and there is no firewall on the remote machine....there is a firewall on this machine but I have disabled it...

gn2
August 2nd, 2009, 01:17 PM
You might have to open port 5900 on the routers?

http://www.realvnc.com/support/portforward.html

dunbrokin
August 3rd, 2009, 01:54 AM
Sorryn nothing there seemed to help me open port 5900

dunbrokin
August 3rd, 2009, 02:09 AM
Apologies to all....problem solved....basic user error....

hellmet
August 3rd, 2009, 04:26 AM
And that was? You owe the community an answer, my friend.

dunbrokin
August 3rd, 2009, 05:49 AM
While Remote Viewer was switched on in the master pc it was actually switched on in the slave PC.....I was sure it was.....checking again revealed otherwise...

HermanAB
August 3rd, 2009, 05:55 AM
Please note that VNC is insecure and a prime reason why Ubuntu machines get hacked. Rather install SSH. It is secure and can do everything VNC does and much more.

dunbrokin
August 3rd, 2009, 06:00 AM
This is behind my firewall....

HermanAB
August 3rd, 2009, 07:35 AM
VNC is OK on a LAN. Just don't ever expose it to the Wild Wild World.

LarryJ2
November 4th, 2009, 06:09 PM
I have two pcs in a local LAN. One is Karmic and the other is Hardy updated. I kept getting the "connection to host was closed" error message from Karmic while attempting to connect to Hardy until I opened up System->Preferences->Remote Desktop->Advanced on the Hardy machine then UNCHECKED the box by "only allow local connections".

Now that would seem expose this PC to the internet but I am behind a wireless / router firewall anyway. Steve Gibsons grc.com doesn't show any open 5900 port and the remote desktop program "vinagre" (Applications -> Internet -> Remote Desktop Viewer) is working again.

Un- checking this box certainly is counter intuitive. A bug?