PDA

View Full Version : [ubuntu] .bin wont install



Tripytaka
July 21st, 2009, 01:25 AM
Hi All,

I am a MS convert new to Ubuntu and I hope to never use MS again! I am running Ubuntu Server 9.04 (32bit) on a Dell Power Edge 840.

I followed the tutorial “Perfect Server 9.04 ISPConfig3” and have set up my server to be an ISP and can access my website from the outside world. I have installed Joomla and in folders under Joomla Moodle, JFusion and Lime Survey. Everything is working perfect.

The last part of my plan is causing me some grief. I want to install the Jasper Soft BI Suite. I have downloaded “jasperserver-3.5.0-linux-installer.bin” and it is sitting on my desktop.


I have studied forums, websites and the great “How to install ANYTHING in Ubuntu”, but when I follow the instructions to install a .bin file the installation fails.


I open the terminal and here's what I enter:


cd Desktop
ls
sudo chmod +x jasperserver-3.5.0-linux-installer.bin
./jasperserver-3.5.0-linux-installer.bin



Here is the result.


myuser@myserver:~$ cd Desktop
myuser@myserver:~/Desktop$ ls

administration-console jasperserver-3.5.0-bin.zip
jasperserver-3.5.0-linux-installer.bin
BI Software
How to install ANYTHING in Ubuntu.pdf

myuser@myserver:~/Desktop$ sudo chmod +x jasperserver-3.5.0-linux-installer.bin

myuser@myserver:~/Desktop$ ./jasperserver-3.5.0-linux-installer.bin
bash: ./jasperserver-3.5.0-linux-installer.bin: No such file or directory

myuser@myserver:~/Desktop$




Why is it telling me: No such file or directory” when the 'ls' command clearly shows the .bin sitting on my desktop? Is there a step I am missing?


According to the tutorials and forums the above command should launch the .bin into action the same way double clicking an .exe does. But for me it does not.



How do I get this thing to install. I am old-school .exe and this .bin process is causing me grief. I am familiar with .bin as a mountable image file, but I cannot burn an image with the jasperserver-3.5.0-linux-installer.bin


One thing I thought of could be this part of the “Perfect Server” tutorial.
http://www.howtoforge.org/perfect-server-ubuntu-9.04-ispconfig-3-p3


9 Change The Default Shell

/bin/sh is a symlink to /bin/dash, however we need /bin/bash, not /bin/dash. Therefore we do this:
dpkg-reconfigure dash
Install dash as /bin/sh? <-- No
If you don't do this, the ISPConfig installation will fail.


Can someone please point me in the right direction. I have tried to help myself by reading all the forums I can find, following the instructions, but this .bin has got me beat.


Please help. Any and all assistance is greatly appreciated.


Regards -Tripytaka

wojox
July 21st, 2009, 01:34 AM
sudo ./jasperserver-3.5.0-linux-installer.bin

The default shell is BASH

Tripytaka
July 21st, 2009, 01:43 AM
Thanks wojox,

I appreciate your prompt reply.

I adjusted my script to include:

sudo ./jasperserver-3.5.0-linux-installer.bin

This time i get: Unable to execute - No such file or directory.

Regards - Tripytaka

wojox
July 21st, 2009, 01:48 AM
Never dealt with JasperServer but if you go to this site you can download an install pdf

http://sourceforge.net/projects/jasperserver/files/

Tripytaka
July 21st, 2009, 01:51 AM
Thanks wojox,

I have the Jasper Server installation docs and followed them. I have installed Apache Tomcat, latest Java and other bits needed. But there were all in the repositories and not .bin. I have also installed tarballs successfully - its just this .bin that has me pulling my hair out.

Here is latest script. I have left out the "ls" as we know it is on the desktop.

myuser@myserver:~$ cd Desktop
myuser@myserver:~/Desktop$ sudo chmod +x jasperserver-3.5.0-linux-installer.bin
myuser@myserver:~/Desktop$ sudo ./jasperserver-3.5.0-linux-installer.bin
sudo: unable to execute ./jasperserver-3.5.0-linux-installer.bin: No such file or directory
myuser@myserver:~/Desktop$



Regards - Tripytaka

wojox
July 21st, 2009, 02:03 AM
Try


chmod 755 jasperserver-3.5.0-linux-installer.bin

Tripytaka
July 21st, 2009, 02:14 AM
Thanks wojox,

Added the "chmod 755" and still get the same result.

Properties>permissions of the jasperserver-3.5.0-linux-instaler.bin and set to: allow executing file as program.

I really appreciate your assistance.

Latest Script:

myuser@myserver:~$ cd Desktop
myuser@myserver:~/Desktop$ sudo chmod 755 jasperserver-3.5.0-linux-installer.bin
myuser@myserver:~/Desktop$ sudo ./jasperserver-3.5.0-linux-installer.bin
sudo: unable to execute ./jasperserver-3.5.0-linux-installer.bin: No such file or directory
myuser@myserver:~/Desktop$


From my research, the script is correct. There must be some setting within Ubuntu that is blocking the .bin from installing?


Regards - Tripytaka.

Tripytaka
July 21st, 2009, 02:26 AM
I have also tried installing different .bin files using the same script (substituting file name) and still get the same result.

Regards - Tripytaka