PDA

View Full Version : [ubuntu] USB Microphone Problem



Zopiac
July 14th, 2009, 12:13 PM
I have a USB microphone that has worked fine on Ubuntu before, but on this computer, it is having problems. It has always displayed as Logitech USB Microphone in the Sound Preferences, but on this computer it just shows up as USB Input in the Sound Capture box. However, when I have even that selected, I do not get input. In the Device Drop-Down box in Sound Preferences, at the bottom, it lists it fine, but it just doesn't allow me to use it as my Sound Capture device. How do I get this to work?

khelben1979
July 14th, 2009, 01:43 PM
What is the brand of the USB Microphone?

If the Linux kernel have inbuilt support for that hardware it will work automatically, as it probably did before. Otherwise you either need to build it as a kernel module or switch to another Linux kernel.

Zopiac
July 15th, 2009, 03:19 AM
What is the brand of the USB Microphone?

If the Linux kernel have inbuilt support for that hardware it will work automatically, as it probably did before. Otherwise you either need to build it as a kernel module or switch to another Linux kernel.

It is Logitech, as I stated (but it mght not have been exactly obvious)

What do you mean, about the kernel?

cooper77z
July 15th, 2009, 03:26 AM
dude, I had problems after using a logitech usb mic too! Darnet! I am afraid to use it again, though I might just to prove them to be malicious. It's an hour and a half penalty if I am right or wrong.

khelben1979
July 15th, 2009, 04:20 PM
It is Logitech, as I stated (but it mght not have been exactly obvious)

The exact model number from Logitech is interesting to know about.


What do you mean, about the kernel?

That you probably need another kernel with better support for your Logitech hardware. Your present kernel supports it, but it may not be using the correct driver for it (I don't know).

Zopiac
July 15th, 2009, 05:00 PM
The exact model number from Logitech is interesting to know about.

Uhm... Rock Band Microphone? ^_^ It's really all I have on it. It works perfectly fine on my other computers (Ubuntu Studio 9.04 and Windows XP) but not on this one (Ubuntu 8.04). (Technically it doesn't work on my Kubuntu 9.04 computer either, but I can't get sound to fully work on it anyways)

cooper77z
July 17th, 2009, 01:34 AM
My rock band usb mic worked great in 8.04, but I think I messed up my system while I was modifying the way my system used the mic.

Zopiac
July 28th, 2009, 07:11 PM
Bump? I need the mic to work; this is my audio production computer ^_^ and I'm too cheap to get an actual mic.

sandeepraj
July 28th, 2009, 07:24 PM
try updating kernal..


sudo apt-get update