PDA

View Full Version : [ubuntu] Jaunty no sound laptop



ex-wirecutter
July 12th, 2009, 05:15 PM
I have just installed Jaunty (dual boot) on my intel based laptop but no sound. Have tried all previous suggestions but no luck . Sound o.k. in windows . Could use Jaunty without sound but would like to get it working .

halitech
July 12th, 2009, 05:17 PM
what kind of laptop?

can you post the results of
lshw -C sound
lspci
aplay -l

ex-wirecutter
July 12th, 2009, 05:22 PM
Compaq Presario 2700

ex-wirecutter
July 12th, 2009, 05:25 PM
multimedia
description: Multimedia audio controller
product: 82801CA/CAM AC'97 Audio Controller
vendor: Intel Corporation
physical id: 1f.5
bus info: pci@0000:00:1f.5
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=Intel ICH latency=0 module=snd_intel8x0
len@len-laptop:~$

northern lights
July 12th, 2009, 05:28 PM
lshw -C sound
Must have gotten mixed up here. 'sound' is not a valid class - you're looking for 'multimedia'.

Please post the output of
sudo lshw -C multimediaplus aplay -l as requested by halitech.

ex-wirecutter
July 12th, 2009, 05:29 PM
**** List of PLAYBACK Hardware Devices ****
card 0: I82801CAICH3 [Intel 82801CA-ICH3], device 0: Intel ICH [Intel 82801CA-ICH3]
Subdevices: 1/1
Subdevice #0: subdevice #0
len@len-laptop:~$

ex-wirecutter
July 12th, 2009, 05:32 PM
**** List of PLAYBACK Hardware Devices ****
card 0: I82801CAICH3 [Intel 82801CA-ICH3], device 0: Intel ICH [Intel 82801CA-ICH3]
Subdevices: 1/1
Subdevice #0: subdevice #0
len@len-laptop:~$ sudo lshw -c multimedia
[sudo] password for len:
*-multimedia
description: Multimedia audio controller
product: 82801CA/CAM AC'97 Audio Controller
vendor: Intel Corporation
physical id: 1f.5
bus info: pci@0000:00:1f.5
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master

halitech
July 12th, 2009, 05:32 PM
Must have gotten mixed up here. 'sound' is not a valid class - you're looking for 'multimedia'.

Please post the output of
sudo lshw -C multimediaplus aplay -l as requested by halitech.

not confused unless ubuntu took it out cause here's mine on Debian


daryl@debian:~$ lshw -C sound
WARNING: you should run this program as super-user.
*-multimedia
description: Multimedia audio controller
product: SB Live! EMU10k1
vendor: Creative Labs
physical id: 5
bus info: pci@0000:02:05.0
version: 0a
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=EMU10K1_Audigy latency=64 maxlatency=20 mingnt=2 module=snd_emu10k1
daryl@debian:~$

halitech
July 12th, 2009, 05:34 PM
none the less, hardware looks like it is being seen fine. Have you checked alsamixer to make sure nothing is muted?

ex-wirecutter
July 12th, 2009, 05:36 PM
**** List of PLAYBACK Hardware Devices ****
card 0: I82801CAICH3 [Intel 82801CA-ICH3], device 0: Intel ICH [Intel 82801CA-ICH3]
Subdevices: 1/1
Subdevice #0: subdevice #0

ex-wirecutter
July 12th, 2009, 05:38 PM
Have checked alsa mixer . nothing muted , all controls turned up full

gamerchick02
July 12th, 2009, 05:42 PM
Hey there.

I know this is a very simple check, but have you made sure you don't have the "external amplifier" checked?

On my Gateway, I noticed that was the biggest issue.

Good luck!

Amy

ex-wirecutter
July 12th, 2009, 05:45 PM
Thanks for your suggestion , where do I find that option ?

ex-wirecutter
July 12th, 2009, 05:53 PM
Thanks everyone , I will just have to keep trying or use it without sound .

halitech
July 12th, 2009, 06:02 PM
did you run alsamixer from the terminal? it should be listed there if it has it. you might also need to mute the headphones to get sound out of the onboard speakers.

ex-wirecutter
July 12th, 2009, 06:24 PM
Everything seems to check out o.k. but no sound . Never mind I can always use windows for sound , or , perhaps try Hardy , never had any trouble with that .

gamerchick02
July 13th, 2009, 01:33 AM
Thanks for your suggestion , where do I find that option ?


Right click on the volume icon on your panel, and click on "volume control". Click on the "switches" tab, and there should be a switch for "external amplifier".

If there is no "switches" tab, enable it by hitting the "preferences" button and check the "external amplifier" button. Then you should be able to go to the "switches" tab.

Make sure the checkbox by external amplifier isn't checked. Hit close, and you should be set.

Amy

aysiu
July 13th, 2009, 02:30 AM
I had this problem, and this was the fix:
https://bugs.launchpad.net/netbook-remix/+bug/318942/comments/44

ex-wirecutter
July 14th, 2009, 04:06 PM
Thanks for the suggestion but external amplifier is not checked .
I think the problem may be with alsa mixer attenuating the sound , I had this on my desktop pc and had to use an amplifier . Is there any alternative to alsa mixer ?