PDA

View Full Version : Cleartype/Anti-Aliasing/Subpixel-Smoothing fonts in WINE



There Was A Time
July 11th, 2009, 11:31 AM
I have the latest version of Wine installed and managed to get MS Office 2007 installed without any problems. Except it has become evident, that fonts do not use window's Cleartype, and appear ugly and jagged.

Is there a way to turn on Cleartype? I've tried changing fontsmoothing "0" user.reg to "1", but that had no effect.

Okay, with a registry tweak, I've got most fonts working, but Calibri and Cambria refuse to render properly. I have them working in Ubuntu with a fonts.conf edit, but that change hasn't carried over.

Has anyone had any luck with this, as from searching for screenshots, I've found that people have it enabled.

Jonathan Moerman
June 14th, 2011, 06:43 PM
I've posted this on several threads:

This is very easy to fix:
1. install FontForge
2. navigate to the fonts directory.
3. open the font you want (Calibri) and do NOT import the bitmaps fonts
4. file -> generate fonts : save as TrueType and with the option "No Bitmap Fonts" (and I recommend to disable the validate before saving option)
5. rename and replace the font
6. repeat this with the Italic and bold variants

this fixes the problem for calabri and cambria.

Brebs
June 16th, 2011, 02:22 PM
You probably the 2 tweaks (embeddedbitmap false and scalable false) in ~/.fonts.conf - see post (http://forums.gentoo.org/viewtopic-p-6183606.html#6183606) in huge fonts thread.

Jonathan Moerman
June 16th, 2011, 07:56 PM
wine doesn't read the .fonts.conf file so that doesn't work