PDA

View Full Version : [ubuntu] 9.04 on a Pismo Laptop (Powerbook G3 Firewire)



MJMullinII
July 9th, 2009, 08:39 AM
Hello everyone.

I just yesterday decided to give my Pismo new life by installing Ubuntu 9.04 on it. The install went flawlessly (though I did need to use the alternative CD).

However, on boot, the xserver screen is garbled (weird colors and streaks/lines throughout).

I figure it's the graphics setting, but for the life of me I can't figure out how to fine tune it. I've used Linux a little in the past and always was directed to the xorg.conf file, but it now seems to be completely empty (I'm to understand Ubuntu handles display settings elsewhere).

My question is simple: Have any Ubuntu 9.04 PowerPC users managed to get a successful install *and* successfully running xserver system going on a Pismo?

If so, what settings do I need to change from the Console (as I can't get to a GUI)?

Just for sake of completeness, the Pismo has a Rage128 Mobility Video Card (AGP x2) with 8 MBs of Ram.

Any help would be appreciated *very* much!
TIA.

MJMullinII
July 12th, 2009, 07:32 AM
and SOLVED!!!!!!!!!!!!!!!!!!!!!

I don't mind telling you this was a little more work than I thought (though nowhere near as difficult as the OldWorld mac installs :))

After jumping through reinstall after reinstall (bouncing between Yellow Dog Linux and back to Ubuntu, etc.) I have a fully working Xorg Server!!!

I'll skip right to the chase for anyone who might be trying the same on similar hardware:


Section "Device"
Identifier "Configured Video Device"
Driver "ati"
Option "AGPMode" "2"
BusID "PCI:0:16:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 28-51
VertRefresh 43-60
# Option "dpms" "on"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection



You take a default install of Ubuntu Jaunty...

Switch to Console 1 (assuming your screen is screwed, etc. in X11)

Run


dpkg-reconfigure -phigh xserver-xorg

To get rid of the completely blank xorg.conf and give you something to start with.

After dpkg runs,


nano sudo /etc/X11/xorg.conf

Simply replace everything relevant with the copy above.

NOW!!! A note about the screen, those frequencies work fine with *MY* Pismo's LCD, YMMV.

However, I'm convinced the hardware part (make sure to include the AGP comments, else it will try to drive the Rage 128 card in AGP X1 mode instead of AGP X2, not much difference, but it did bump FPS from around 250 -> 450, so no reason to ignore it :))

I'm hoping this might be helpful to anyone with a similar aged machine (I'm thinking several models of iMac also came with this hardware setup, though the monitor frequencies are undoubtedly different).

Anyway, I'm hoping it saves someone else from frustration!

goatkeeper
October 25th, 2009, 08:33 AM
I have a g3 ibook 500mh, 640RAM. Running Jaunty okay after .conf change. Everything works and it doesn't seem slow at all. But the cursor hops and sometimes it disappears. I can be typing along and suddenly no cursor. It can be gone off into another file. No kidding. I have tried to change various settings. Wow. I don't know if it is hardware or a bug.

natgab
October 30th, 2009, 04:39 AM
I have a g3 ibook 500mh, 640RAM. Running Jaunty okay after .conf change. Everything works and it doesn't seem slow at all. But the cursor hops and sometimes it disappears. I can be typing along and suddenly no cursor. It can be gone off into another file. No kidding. I have tried to change various settings. Wow. I don't know if it is hardware or a bug.


---Same thing here. Using either KDE or LXDE I get a twitchy mouse pointer and every time I want to access the menu on an application (file,edit,etc...) I have to click it fast several times for it to "catch", then I can click once and get the menu. The main K menu works fine, but I also have trouble with the applets on the menu bar. It won't let me right click most of the time.

I have a G3 iMac 400MHz, and finally got it to work. I loaded Debian Lenny 5.03 since I had trouble with Ubuntu 9.04 on it. My tutorial: http://ubuntuforums.org/showthread.php?t=1283932.

hanzomon4
October 30th, 2009, 08:05 AM
and SOLVED!!!!!!!!!!!!!!!!!!!!!

I don't mind telling you this was a little more work than I thought (though nowhere near as difficult as the OldWorld mac installs :))

After jumping through reinstall after reinstall (bouncing between Yellow Dog Linux and back to Ubuntu, etc.) I have a fully working Xorg Server!!!

I'll skip right to the chase for anyone who might be trying the same on similar hardware:



You take a default install of Ubuntu Jaunty...

Switch to Console 1 (assuming your screen is screwed, etc. in X11)

Run



To get rid of the completely blank xorg.conf and give you something to start with.

After dpkg runs,



Simply replace everything relevant with the copy above.

NOW!!! A note about the screen, those frequencies work fine with *MY* Pismo's LCD, YMMV.

However, I'm convinced the hardware part (make sure to include the AGP comments, else it will try to drive the Rage 128 card in AGP X1 mode instead of AGP X2, not much difference, but it did bump FPS from around 250 -> 450, so no reason to ignore it :))

I'm hoping this might be helpful to anyone with a similar aged machine (I'm thinking several models of iMac also came with this hardware setup, though the monitor frequencies are undoubtedly different).

Anyway, I'm hoping it saves someone else from frustration!

Can it run compiz? Although I've been getting into the Awesomewm look but it would still be nice to have the option of running compiz

LtPitt
January 29th, 2010, 12:11 PM
Things slightly changed in 9.10

I've been messing a bit and I've found out that right now you get no old-style xorg.conf output from a

sudo dpkg-reconfigure xserver-xorg.


No problem!

Open terminal and go in the X11 config folder:

cd /etc/X11

Here create a xorg.conf file with the editor you prefer:

sudo nano xorg.conf (you can digit gedit or leafpad or mousepad or any text editor you like instead of nano)

and in xorg JUST digit these:


Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection


Save it and digit

startx

BAM.
Your colors are safe! :)

ps
why 16 bits when you can have 24? :D

KingYaba
April 26th, 2010, 09:43 PM
I'm trying what the OP has posted, but I keep getting a "No Such file or directory" after typing all that display info. How do I create this xorg.conf file?

linuxopjemac
April 27th, 2010, 07:55 AM
sudo nano /etc/X11/xorg.conf

paste the text in it
CTRL-X and "y" to exit and save

You might want to try my Pismo file for Karmic Koala:
http://mac.linux.be/content/xorgconf-file-pismo-karmic-koala