PDA

View Full Version : [ubuntu] 9.04/XP dual boot desktop; Belkin F5D7050 adapter- trouble connecting to network.



Thomas Anthony
July 8th, 2009, 04:48 PM
I have a self-built AMD Athlon 64 PC, onto which I installed Ubuntu 9.04 desktop yesterday, in dual boot with Windows XP. I have a Belkin F5D7050 network adapter working with Windows XP to connect to the internet, and have been trying to get the same network connection in Ubuntu so that I can access the internet from it.
---------------------------------------------
$ lsusb gives:

Bus 001 Device 004: ID 050d:705a Belkin Components F5D7050A Wireless Adapter


---------------------------------------------
~$ iwconfig wlan0

wlan0 IEEE 802.11g ESSID:off/any

Mode:Auto Frequency:2.412 GHz Access Point: Not-Associated

Bit Rate:11 Mb/s Tx-Power:20 dBm Sensitivity=-121 dBm

RTS thr=2347 B Fragment thr=2346 B

Power Management:off

Link Quality:0 Signal level:0 Noise level:0

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

-----------------------------------------------
~$ lsmod

~$ dmesg

How do I find the “wlan_module_name”? So that I can find just the useful information from these?
-----------------------------

~$ sudo lshw -C network



*-network

description: Ethernet interface

product: RTL-8139/8139C/8139C+

vendor: Realtek Semiconductor Co., Ltd.

physical id: b

bus info: pci@0000:02:0b.0

logical name: eth0

version: 10

serial: 00:01:2e:0b:3d:3e

size: 10MB/s

capacity: 100MB/s

width: 32 bits

clock: 33MHz

capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation

configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s

*-network:0

description: Wireless interface

physical id: 1

logical name: wlan0

serial: 00:11:50:bb:10:7d

capabilities: ethernet physical wireless

configuration: broadcast=yes driver=ndiswrapper+rt73 driverversion=1.53+Belkin,08/02/2005, 1.00.00. link=no multicast=yes wireless=IEEE 802.11g

*-network:1 DISABLED

description: Ethernet interface

physical id: 2

logical name: pan0

serial: 3a:a6:30:a8:74:ac

capabilities: ethernet physical

configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

*--------------------------------------------
~$ iwlist scan



wlan0 Scan completed :

Cell 01 - Address: 00:22:3F:4A:B0:16

ESSID:"SKY59455"

Protocol:IEEE 802.11g

Mode:Managed

Frequency:2.437 GHz (Channel 6)

Quality:12/100 Signal level:-88 dBm Noise level:-96 dBm

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s

6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s

36 Mb/s; 48 Mb/s; 54 Mb/s

Extra:bcn_int=100

Extra:atim=0

IE: WPA Version 1

Group Cipher : TKIP

Pairwise Ciphers (1) : TKIP

Authentication Suites (1) : PSK

Cell 02 - Address: 00:1B:2F:FE:F9:5C

ESSID:"NETGEAR"

Protocol:IEEE 802.11g

Mode:Managed

Frequency:2.462 GHz (Channel 11)

Quality:15/100 Signal level:-86 dBm Noise level:-96 dBm

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s

12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s

48 Mb/s; 54 Mb/s

Extra:bcn_int=100

Extra:atim=0

IE: WPA Version 1

Group Cipher : TKIP

Pairwise Ciphers (1) : TKIP

Authentication Suites (1) : PSK

Cell 03 - Address: 00:14:A5:54:4F:EF

ESSID:"21jen"

Protocol:IEEE 802.11g

Mode:Managed

Frequency:2.412 GHz (Channel 1)

Quality:62/100 Signal level:-56 dBm Noise level:-96 dBm

Encryption key:on

Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s

24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s

12 Mb/s; 48 Mb/s

Extra:bcn_int=100

Extra:atim=0

IE: WPA Version 1

Group Cipher : TKIP

Pairwise Ciphers (1) : TKIP

Authentication Suites (1) : PSK


(NOTE: I am attempting to connect to the 21jen network)

---------------------------------------------

~$ lsb_release -d

Description: Ubuntu 9.04

~$ uname -mr

2.6.28-11-generic i686

---------------------------------------------
~$ sudo /etc/init.d/networking restart

* Reconfiguring network interfaces... [ OK ]
----------------------------------------------

I installed ndiswrapper in accordance to the guide here: https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper


Following this "route", as it were:
2.2
3.1
3.2.2
3.3 (using the driver CD)
3.4.1
3.5

Giving: thomas@thomas-desktop:~$ sudo depmod -a

sudthomas@thomas-desktop:~$ sudo modprobe ndiswrapper

WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.

WARNING: /etc/modprobe.d/blacklist line 1: ignoring bad line starting with 'ihufilkjnafkjbnol;k'
thomas@thomas-desktop:~$ tail /var/log/messages

Jul 8 15:53:04 thomas-desktop kernel: [ 16.757421] [drm] Setting GART location based on new memory map

Jul 8 15:53:04 thomas-desktop kernel: [ 16.758083] [drm] Loading R300 Microcode

Jul 8 15:53:04 thomas-desktop kernel: [ 16.758103] [drm] Num pipes: 1

Jul 8 15:53:04 thomas-desktop kernel: [ 16.758109] [drm] writeback test succeeded in 1 usecs

Jul 8 15:53:08 thomas-desktop kernel: [ 20.284958] eth0: link down

Jul 8 15:53:08 thomas-desktop kernel: [ 20.285273] ADDRCONF(NETDEV_UP): eth0: link is not ready

Jul 8 15:53:08 thomas-desktop kernel: [ 20.286302] ADDRCONF(NETDEV_UP): wlan0: link is not ready

Jul 8 15:53:43 thomas-desktop pulseaudio[3055]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Jul 8 15:53:43 thomas-desktop pulseaudio[3055]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Jul 8 16:13:01 thomas-desktop -- MARK --

thomas@thomas-desktop:~$



Here I stopped because I wasn't confident with what I should be doing- things were not as expected by the instructions.

-------------------------------------
When Opening System → Administration → Windows Wireless Drivers, and entering my password, I get a message saying “unable to see if hardware is present” Then the following screenshot:

http://phpdiplomacy.tournaments.googlepages.com/Screenshot-WirelessNetworkDrivers.png/
http://phpdiplomacy.tournaments.googlepages.com/Screenshot-WirelessNetworkDrivers.png


On clicking the bar chart type symbol top right (next to volume control and date/time), I can see my router and various others, but when I click on it and enter the password, the connect button is shaded grey (un-press-able).
--------------------------------------
How do I make the network work, or what do I need to do to provide sufficient information for somebody to be able to tell me how?

Thanks in advance

Thomas.

Thomas Anthony
July 9th, 2009, 07:16 PM
Am I allowed to bump if I haven't a response?

superprash2003
July 9th, 2009, 08:12 PM
try setting the wifi network to be an open network without any password just temporarily to see if it works