PDA

View Full Version : [ubuntu] Epia M, VIA C3 processor, incompatible kernel



crazyaxe
July 8th, 2009, 09:13 AM
Hello everybody.
I'm trying to install Ubuntu 9.04 on a VIA C3 Epia M PC.
512Mb RAM
533MHz fanless

but works only the liveCD boot.
If I try to install I obtain only a black screen.
Is there any installation without graphic?
Please help.

However I obtain the same result with Mandriva, but not with Slackware. I don't know why Slackware 12 works.

Kuno81
July 10th, 2009, 07:46 AM
Hi crazyaxe,

the Live-CD boot menu offers some option. One is something like "video safe mode", i guess...
Keep on trying, i installed the 9.04 on my Epia M10000 few days ago. Everything works out-of-the-box. Except the hardware rendering doesn't work perfectly, but it works.

Good luck!

lavinog
July 27th, 2009, 07:38 AM
I have the 800Mhz (fan) version. My system crashes within minutes of booting.
Apparently this has something to do with a module called longhaul being compiled into the kernel.
This page:http://bugzilla.kernel.org/show_bug.cgi?id=10062 seems to mention that longhaul is very buggy with the older via boards, and it isn't included in the kernel because of instability. For some reason it is enabled by default in ubuntu: CONFIG_X86_LONGHAUL=Y
I will try and compile a custom kernel with this dissabled later this week to see if this fixes the issue.

lavinog
July 30th, 2009, 05:31 AM
adding notsc to the kernel options at boot seemed to fix my epia issues. You may want to give it a try.