PDA

View Full Version : [SOLVED] Ver el escritorio de mi pc en la tv



x_jefesin_x
July 2nd, 2009, 01:56 AM
Hola a todos, ojalas que me puedan ayudar ;)

Me compre un cable para conectar mi tarjeta de grafica NVIDA GeForce 6200 A-LE
a la tv pero, como lo sospechaba, tengo que configurar algo, por que no me da ninguna imagen en la tv.

Saben que tengo que configurar y como ?

Uso ubuntu 9.04 y como mencione mi targeta grafica es GeForce 6200 A-LE

saludos...):P

pd: falta algun dato ?

kamus
July 2nd, 2009, 02:20 AM
Compraste un cable RGB o lo enchufaste a alguna salida de la misma tarjeta grafica (HDMI, TVOUT, etc)?

Aqui la tengo enchufada a mi salida HDMI y tambien la he probado directo con RGB y solo fue cosa de configurar la resolucion con nvidia-settings.

Saludos

x_jefesin_x
July 2nd, 2009, 02:33 AM
Mira tengo exactamente salida en mi tarjeta gráfica (1) la que sale marcada con B
y conecto ese cable a la entrada de video de mi tv .

Este es el cable que compre (2)

gracias por responder.

Referencias
1 http://www.weethet.nl/images/pc2tv/tvout_examples_videocards.jpg
2 http://img.alibaba.com/photo/205249940/S_Video_7_Pin_to_RGB_Pr_Pb_Y_Out_Converter_TV_AV_C able.jpg

PD: no se el lenguaje técnico :P

kamus
July 2nd, 2009, 03:12 AM
Mira tengo exactamente salida en mi tarjeta gráfica (1) la que sale marcada con B
y conecto ese cable a la entrada de video de mi tv .

Este es el cable que compre (2)

gracias por responder.

Referencias
1 http://www.weethet.nl/images/pc2tv/tvout_examples_videocards.jpg
2 http://img.alibaba.com/photo/205249940/S_Video_7_Pin_to_RGB_Pr_Pb_Y_Out_Converter_TV_AV_C able.jpg

PD: no se el lenguaje técnico :P

Este link https://help.ubuntu.com/community/NvidiaTVOut deberia servir como base para lo que quieres hacer.

Saludos

bichopro
July 2nd, 2009, 03:44 AM
Yo lo hago instalando el nvidia server setings desde synaptic y lo configuro en la segunda opcion que algo como display configuration, y con eso listo, pero lo hago con la salida de svideo

CdK1
July 2nd, 2009, 03:53 AM
Si tienes Nvidia puedes usar nvidia-settings.

ó

Haz una copia de tu xorg.conf y edita la sección "Screen" de la siguiente manera:

Section “Device”
Identifier “TARJETA″
Driver “nvidia”

Option “AllowGLXWithComposite” “False”
Option “CursorShadow” “on”
Option “RenderAccel” “False”
Option “TwinView”
Option “TwinViewOrientation” “Clone”
Option “SecondMonitorHorizSync” “31.5″
Option “SecondMonitorVertRefresh” “50-70″
Option “MetaModes” “1280,1024,800×600″
Option “ConnectedMonitor” “CRT, TV”
Option “TVStandard” “PAL-NC”
Option “TVOutFormat” “COMPOSITE”
EndSection

x_jefesin_x
July 2nd, 2009, 08:12 PM
Necesito un poco de ayuda para configurar el xorg por que lo hize mal XD,
les mando la copia de mi configuración para que me echen una manito :)
por que estoy un poco confundido de donde poner los códigos que me mandan kamus (http://ubuntuforums.org/member.php?u=318491) y CdK1 (http://ubuntuforums.org/member.php?u=851995) por que como veran tengo 2 secciones Screen y tambien 2 de Device.
Al final del código vi esto:

Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1152x864_60 +0+0"podrá ser un acercamiento al problema?
Agradezco su interés
Saludos...


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 A-LE"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1152x864_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

asterix77
July 2nd, 2009, 10:23 PM
¿No será un problema de resolución de tu TV?. A mi pasó que cuando quice conectar mi pc con Jaunty y una tarjeta de video Nvidia geforce 9600 no se vio nada, y fue porque la resolución no era sopotada por mi tv (al parecer no la detectó en forma automática). Lo arreglé con nvidia-setting ajustando la resolución y listo


Saludos

x_jefesin_x
July 3rd, 2009, 01:12 AM
Lo estamos logrando...:p
Ahora llega señal a la tv pero se ve negro y movedizo (ojo negro no blanco y negro)
veo el fondo de escritorio pero con muy poca opacidad, debe ser un problema de las normas de las tv's en chile NTSC-M, yo creo que me la esta enviando en pal u otro parecido.

Como puedo cambiar para que mande la señal en NTSC-M ?, tienen mi xorg en que parte lo pongo esa config?

o

Que cree que puede estar pasando ??

De ante mano gracias
Adios.

CdK1
July 3rd, 2009, 01:34 AM
Option “TVStandard” “” ==> Esa es la opción y ten en cuenta que las secciones Device y Screen que tienes debes unirlas y que quede una de cada una..., suprimes lo que se repite, por lo que ví tienes dos veces "Driver nvidia", etc...

kamus
July 3rd, 2009, 02:07 AM
Si tienes Nvidia puedes usar nvidia-settings.

ó

Haz una copia de tu xorg.conf y edita la sección "Screen" de la siguiente manera:

Section “Device”
Identifier “TARJETA″
Driver “nvidia”

Option “AllowGLXWithComposite” “False”
Option “CursorShadow” “on”
Option “RenderAccel” “False”
Option “TwinView”
Option “TwinViewOrientation” “Clone”
Option “SecondMonitorHorizSync” “31.5″
Option “SecondMonitorVertRefresh” “50-70″
Option “MetaModes” “1280,1024,800×600″
Option “ConnectedMonitor” “CRT, TV”
Option “TVStandard” “PAL-NC”
Option “TVOutFormat” “COMPOSITE”
EndSection

Eso lo debes cambiar a NTSC-M jefesin.., en el wiki que te postie anteriormente aparece la tabla con las normas para cada pais, por eso ves blanco y negro tu pantalla.

Saludos

Saludos

kamus
July 3rd, 2009, 02:37 AM
Option “TVStandard” “” ==> Esa es la opción y ten en cuenta que las secciones Device y Screen que tienes debes unirlas y que quede una de cada una..., suprimes lo que se repite, por lo que ví tienes dos veces "Driver nvidia", etc...




# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection


Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Identifier "Monitor" #CRT
HorizSync 28-55
VertRefresh 43-72
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Television" #TV
HorizSync 30-50
VertRefresh 60
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 A-LE"
EndSection


Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor"
DefaultDepth 24
Option "ConnectedMonitor" "CRT"
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Television"
DefaultDepth 24
Option "TVOutFormat" "SVIDEO"
Option "TVStandard" "NTSC-M"
Option "ConnectedMonitor" "TV"
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection


Prueba esto..

nopersona
July 6th, 2009, 04:28 AM
Cómo va este entuerto? En la semana me compraré un cable s-video para lo mismo. A ver cómo sale. De momento, todos lo que he visto son demasiado cortos. Pensando seriamente en do-it-yourself.

x_jefesin_x
October 22nd, 2009, 11:31 PM
Se ha solucionado.
La verdad es que al parecer, y lo mas seguro, era un problema de los drivers privativos de nividia.

Ahora ( bueno desde hace un rato que tengo la versión 190.36, no lo había probado antes por que había perdido la esperanza de que funcionara ) que actualice los controladores a la versión 190.36 puedo ver el escritorio en mi tv con la opciónTwinView.

Disidí postear esto por si alguien perdió la esperanza al igual que yo.

Moraleja: Antes de perder la esperanza... espera una actualización en los drivers. :)



Saludos... y gracias a todos.