PDA

View Full Version : [ubuntu] executing 'grub-install hd0 ' failed



impervius
July 1st, 2009, 01:35 PM
Hey, im trying to install Ubuntu on my laptop as the sole operating system. I chose to use the whole disk to install, and it was working fine until it hung for about 30mins on "configuring hardware" 94%, and the it eventually gave an error message saying

executing 'grub-install hd0 ' failed

what should i do?

i am installing from a cd which i downloaded, and there are no errors on the disk.

presence1960
July 1st, 2009, 01:46 PM
Did you do MD5SUM and check the results against Ubuntu hashes?
https://help.ubuntu.com/community/HowToMD5SUM
https://help.ubuntu.com/community/UbuntuHashes

The MD5SUM should match the hashes exactly, if not your iso is corrupted.

impervius
July 1st, 2009, 01:52 PM
i did this:

https://help.ubuntu.com/community/Installation/CDIntegrityCheck?action=show&redirect=CDIntegrityCheck

presence1960
July 1st, 2009, 02:28 PM
i did this:

https://help.ubuntu.com/community/Installation/CDIntegrityCheck?action=show&redirect=CDIntegrityCheck

it is recommended in the how to get ubuntu documentation to do an MD5SUM prior to burning the iso image to CD/DVD.

colau
July 1st, 2009, 02:29 PM
i did this:

https://help.ubuntu.com/community/Installation/CDIntegrityCheck?action=show&redirect=CDIntegrityCheck
Check the .iso file with md5sum


md5sum filename.iso

presence1960
July 1st, 2009, 02:32 PM
https://help.ubuntu.com/community/BurningIsoHowto

RJARRRPCGP
July 1st, 2009, 04:28 PM
Hey, im trying to install Ubuntu on my laptop as the sole operating system. I chose to use the whole disk to install, and it was working fine until it hung for about 30mins on "configuring hardware" 94%, and the it eventually gave an error message saying

executing 'grub-install hd0 ' failed

what should i do?

i am installing from a cd which i downloaded, and there are no errors on the disk.

There's still a good chance that your HDD is bad. Sorry. :(