PDA

View Full Version : [all variants] [HOW-TO] Install UFO AI on Jaunty (9.04) 64-bit



arch0njw
July 1st, 2009, 11:56 AM
I'm new at this how-to thing. The basic process is simple. If found that the "run" file from sourceforge was the best approach. This doesn't install it as a package manager managed software, but it does let you put it somewhere convenient (like your home dir, or other location where you have space).

Download the installer. At the time of writing this the installer was ufoai-2.2.1-linux.run.

To install this, simply type "sh ufoai-2.2.1-linux.run" on the command line and it will launch the installer. That part is very self descriptive.

Now for the hard part. You need to get the game running! This part is likely to vary system to system, so I am going to share the steps I used, but not the specific files.

Install "apt-file", you will need it. (sudo apt-get install apt-file)

Run the ufoai command from the command line. Go to where you installed UFO AI and try to run the "ufoai" command. If the game starts, you are having more luck than I did. If you get what I got, it tells you that there is a missing library. No fear, you can now look it up!

Lookup any missing libraries with apt-file. Look up the library by typing the following: sudo apt-file search library-name

You will be told to rebuild the cache. Follow the instructions and then try searching for the file again.

Install packages to get missing libraries. Now you know the packages in which this file is delivered. Install them right here at the command line with sudo apt-get install package-name-from-apt-file.

Wash, rinse, repeat. Try running ufoai again. Use apt-file to find any libraries that are missing and install the package that contains them. Repeat that until ufoai runs.


That worked for me. I look forward to other people's results.