PDA

View Full Version : [ubuntu] wireless not working after updates - hardy



japhyr
July 1st, 2009, 07:31 AM
Hello all,

I have had a fairly stable system for a long time now. I had not updated my system for a while, so I installed updates today. After installing the updates, I shut down. When I started my computer again later, I could not connect to the internet over wireless. I am connected over a wired connection now.

I have a Dell 600m running Hardy Heron. I have an ATI Radeon RV250 Mobility FireGL 9000 wireless card.

If I run "sudo /etc/init.d/networking restart", this is what I get:

* Reconfiguring network interfaces... Ignoring unknown interface eth2=eth2.
Ignoring unknown interface ath0=ath0.
Ignoring unknown interface wlan0=wlan0.
Ignoring unknown interface eth0=eth0.
eth1: ERROR while getting interface flags: No such device
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; No such device.
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device eth1 ; No such device.
There is already a pid file /var/run/dhclient.eth1.pid with pid 134519072
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth1: ERROR while getting interface flags: No such device
eth1: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth1.


How do I get wireless working again?

The Toxic Mite
July 1st, 2009, 07:42 AM
<snip>
I have a Dell 600m running Hardy Heron. I have an ATI Radeon RV250 Mobility FireGL 9000 wireless card.
</snip>


That might be the graphics card you are describing.

Go to Applications > Accessories > Terminal, and type in this command:


lshw -c networkPost the results when done.

superprash2003
July 1st, 2009, 07:43 AM
post output of
1)iwconfig
2)lshw -C network

at bootup , try choosing a previous kernel version and see if wifi works there..

japhyr
July 1st, 2009, 07:54 AM
Sorry, I got so used to dealing with video card issues for a while that was the only card I could think of.

iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.


lshw -C network:

WARNING: you should run this program as super-user.
*-network:0
description: Ethernet interface
product: BCM4401-B0 100Base-TX
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 02
serial: 00:14:22:ba:e9:45
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=b44 driverversion=2.0 ip=192.168.1.105 latency=32 module=ssb multicast=yes
*-network:1 UNCLAIMED
description: Network controller
product: PRO/Wireless 2915ABG Network Connection
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:02:03.0
version: 05
width: 32 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=32 maxlatency=24 mingnt=3

japhyr
July 1st, 2009, 08:24 AM
Fixed.

I noticed that four of the updates had not installed. I made the mistake of updating over a wireless connection earlier today. I finished the updates over the wired connection, restarted, and wireless works again.

Thank you both for the help.

The Toxic Mite
July 1st, 2009, 09:05 AM
Fixed.

I noticed that four of the updates had not installed. I made the mistake of updating over a wireless connection earlier today. I finished the updates over the wired connection, restarted, and wireless works again.

Thank you both for the help.


Heh! You're welcome! :D

gjb1002
August 4th, 2009, 09:54 PM
I have a more or less identical problem here. I also have Hardy and also updated today after not doing so for a while. Now my wireless interface is gone with similar symptoms. I even discovered that 4 of the updates had not installed, as did the original poster. But I've now installed them via the wired connection, rebooted and my wireless is still gone with the same symptoms.

Here's my versions of the output previously requested. Help greatly appreciated.

sofa-pc : lshw -C network

WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: NetLink BCM5906M Fast Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: eth0
version: 02
serial: 00:1b:38:d0:4f:e6
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=tg3 driverversion=3.86
ip=192.168.0.2 latency=0 module=tg3 multicast=yes
*-network UNCLAIMED
description: Network controller
product: RaLink
vendor: RaLink
physical id: 0
bus info: pci@0000:0c:00.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0


iwconfig


lo no wireless extensions.

eth0 no wireless extensions.

martinbaselier
August 4th, 2009, 10:51 PM
There is no driver loaded for your wireless card.

What's the output of:
sudo lspci -s 0c:00.0 -v
?

gjb1002
August 5th, 2009, 06:38 PM
0c:00.0 Network controller: RaLink Unknown device 0781
Subsystem: RaLink Unknown device 2790
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at f8200000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
Capabilities: [70] Express Endpoint IRQ 0



The driver was working before (obviously). When I originally set it up my wireless card wasn't detected, but I downloaded the RT2860PCI driver source from RaLink's website and built and installed it. After doing

sudo modprobe rt2860sta

I then got it up and running. Executing that command now just produces

FATAL: Module rt2860sta not found.

Any help gratefully received.

gjb1002
August 5th, 2009, 07:17 PM
I found a tip to boot into an older kernel on a different thread. So I did, and then wireless worked fine again. The working kernel is 2.6.24-16-generic, while the newer broken one is 2.6.24-24-generic

I'm still not sure what to do now. For now it would be useful to make this older kernel the default on booting up (without needing to go into the grub menu and select it every time), would appreciate some tips on how to do that.

In the longer run I guess I can't keep an old kernel forever, so it would be useful to find a way to decipher why the new kernel isn't finding my wireless card driver.

MadHatter21
August 5th, 2009, 07:23 PM
Was the update you applied kernel related? The same thing happened to me when I updated the kernel. Try booting off of a different kernel on start up. Turn your system on and click escape. Then try a version of kernel one before the lastest on you are running.

gjb1002
August 5th, 2009, 08:05 PM
MadHatter21,

I guess you missed my second post. I did indeed get it to work with an older kernel. But I still don't know what to do now.

Thanks,
Geoff

MadHatter21
August 5th, 2009, 10:11 PM
Reinstall the drivers and your set. I did the same thing yesterday. For some reason the drivers installed on the earlier kernerl did not carry over to the latest kernel. Try to reinstall the driver and lemme kno

madhatter21

gjb1002
August 6th, 2009, 06:52 AM
OK, I'll try to reinstall the driver when I get a moment. But what did you mean by "my set"?

Crafty Kisses
August 6th, 2009, 07:01 AM
I think he means you're like good to go. I was helping MadHatter yesterday on this issue really in depth, and I finally solved it.

martinbaselier
August 6th, 2009, 08:01 AM
FYI:

If you compiled the driver yourself, you will need to do so again with each kernel update. This is because the driver is in fact a kernel module.

gjb1002
August 9th, 2009, 06:19 PM
Many thanks for the help. I finally recompiled the driver and now it works fine with the new kernel.

I guess I can always hope that at some point a new version of Ubuntu will recognise my wireless card "natively" without me needing to recompile it :)