PDA

View Full Version : [kubuntu] WPA doesnt work in jaunty



Virtualboxbuntu
July 1st, 2009, 06:41 AM
Hello,

I use Kubuntu Jaunty on my desktop. Or at least, I'd like to. I use WPA security on my wireless router, and Jaunty's network manager won't connect to it. Apparently other people also have this problem. My wireless adapter works quite fine in the KDE 3 network manager and Gnome's network manager.

What should I do to make it work with my WPA security? And if you want me to install some other program, just how do I do that if I have no Internet?

In case you're wondering, my laptop has Internet.

Virtualboxbuntu
July 3rd, 2009, 07:43 PM
I solved this by temporarily disabling my WPA security while installing the gnome network manager.

Erbid
July 4th, 2009, 01:40 AM
Update 2009-07-06:

I reloaded Ubuntu 9.04 and updated everything using a wired connection, and rebooted.
I then downloaded the closed source STA driver (and the NVidia video driver) using the "Drivers" tool.
I then used the "attach to a hidden network" option from the NetworkManager status bar icon.
Result: WPA PSK connection to a "hidden" network, reliable through reboots and hibernates.


(edited to save someone the hassle of what I did earlier, which follows)

I used apt-get install wicd to clear things up at last. Yep, apt-get needs internet.

(see also https://bugs.launchpad.net/ubuntu/+source/wireless-tools/+bug/339313 )

What finally worked for me was using wicd.

The first solid connection I got from my wireless was when I broadcast my SSID. But after I went and disabled broadcasting the SSID again, the wireless connection would not stay connected or re-establish.

WPA + no broadcast SSID = "use wicd"!

Step by step:

sudo apt-get install wicd
sudo reboot (To get the nice gui tool wicd-client to go.)

Erbid



What should I do to make it work with my WPA security? And if you want me to install some other program, just how do I do that if I have no Internet?

In case you're wondering, my laptop has Internet.

lucloubier
July 4th, 2009, 10:58 AM
WPA + no broadcast SSID = "use wicd"!

This is true after the latest ubuntu update was applied last night on my IBM laptop T41, but that still does not work on my eeePC 1000HE though !

Erbid
July 6th, 2009, 04:20 PM
I reinstalled Ubuntu 9.04, and installed all the updates using a wired connection, and rebooted.
I then downloaded the closed source STA driver (and the NVidia video driver) using the "Drivers" tool.
I then used the "attach to a hidden network" option from the NetworkManager status bar icon.
Result: WPA PSK connection to a "hidden" network, reliable through reboots and hibernates.

No more "problem" for me. Minor problem resolved by using the STA proprietary Broadcom driver. Pretty much as expected.

Not using Kubuntu this time, could that have been a factor requiring wicd?

Erbid

dksmiffs
July 12th, 2009, 05:40 AM
I use Kubuntu Jaunty on my desktop. Or at least, I'd like to. I use WPA security on my wireless router, and Jaunty's network manager won't connect to it. Apparently other people also have this problem. My wireless adapter works quite fine in the KDE 3 network manager

What should I do to make it work with my WPA security?

I got my Kubuntu Jaunty, SSID not broadcasted, WPA-PSK setup working. My prior problems were very similar to the portion of @Virtualboxbuntu's post I quoted above. Here's a writeup of my configuration, and the steps I follow to make plasma-widget-network-manager work:

http://uncleham.wordpress.com/2009/07/11/kubuntu-904-wpapsk-nobroadcast/