PDA

View Full Version : [ubuntu] video card drivers



adkjoe
June 30th, 2009, 09:48 PM
I'm trying to install my video card drivers and I have downloaded the file and followed the instructions on what to type in the terminal which is at the bottom of this page.

http://www.nvidia.com/object/linux_display_ia32_185.18.14.html

It says to type sh NVIDIA-Linux-x86-185.18.14-pkg1.run into terminal after you have downloaded the file.

When I do that is says cannot open NVIDIA-Linux-x86-185.18.14-pkg1.run

what am I missing here? or what am i doing wrong? thanks!

73ckn797
June 30th, 2009, 10:08 PM
Did you go to System/Administration/Hardware Drivers and looked to see whether there are any recommended drivers? If so, you would probably do better installing those. I use Nvidia and the recommended driver works fine.

adkjoe
June 30th, 2009, 10:33 PM
I have the one ubuntu recommends but I have an nvidia gts8600 card and the best resolution it will let me use is 1024x768 and it's pissing me off because it's a good graphics card and it's capable of much better resolution. your probably right though the drivers I have installed are most likely the best ones but why can't I get better resolution?

73ckn797
June 30th, 2009, 10:52 PM
I have the one ubuntu recommends but I have an nvidia gts8600 card and the best resolution it will let me use is 1024x768 and it's pissing me off because it's a good graphics card and it's capable of much better resolution. your probably right though the drivers I have installed are most likely the best ones but why can't I get better resolution?

Could your monitor be limiting the resolution?

Once you have installed the Nvidia driver recommended, see if it installed the System/Administration/Nvidia X-server Settings. See what you can do in there.

adkjoe
June 30th, 2009, 10:58 PM
Thats where I have been messing around, can't seem to get the resolution higher. I'm using my 32" samsung HD tv as a monitor. A while back when I had windows I could get the resolution real high but when I try to in ubuntu the screen is all off center and stretched out. O well, thanks anyways I appreciate it, I'll just have to keep messing around with it.

lavinog
June 30th, 2009, 11:07 PM
you may need to tweek your xorg.conf to enable higher resolutions.
press alt-f2
then type

gedit /etc/X11/xorg.conf
and post what you get.
Note: the above command will not let you edit that file because you are not opening it as superuser.

adkjoe
June 30th, 2009, 11:29 PM
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

lavinog
June 30th, 2009, 11:33 PM
what resolution do you want to enable?

lavinog
June 30th, 2009, 11:38 PM
alt-f2:

gksudo gedit /etc/X11/xorg.conf

change this section:


Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

to this:


Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSection


On the modes line add any other resolutions you know your monitor can support.

adkjoe
June 30th, 2009, 11:45 PM
I would like to run at least 1360x768 but when I enable that it shifts half the screen off the monitor. But it does support it and that's what it sets it at when you select auto. I changed the code you gave me as well but it didn't change anything in the display options, I thought it might display 1280x1024 but it didn't.

73ckn797
July 1st, 2009, 01:47 AM
The Nvidia driver on my system does run at the maximum monitor setting of 1280 x 1040. Anything beyond that and the display goes partially off screen.

What is the maximum for the TV you speak about?

3rdalbum
July 1st, 2009, 03:15 AM
Unless it's a Full HD TV, the maximum resolution should be 1366 x 768.

If it's a full HD, then 1920 x 1080 is the maximum.

ayenack
July 1st, 2009, 04:09 AM
I'm trying to install my video card drivers and I have downloaded the file and followed the instructions on what to type in the terminal which is at the bottom of this page.

http://www.nvidia.com/object/linux_display_ia32_185.18.14.html

It says to type sh NVIDIA-Linux-x86-185.18.14-pkg1.run into terminal after you have downloaded the file.

When I do that is says cannot open NVIDIA-Linux-x86-185.18.14-pkg1.run

what am I missing here? or what am i doing wrong? thanks!

You need to press:

Ctrl+Alt+F4

to stop GDM and get to the command line and run the command again then when you're done press:

Ctrl+Alt+F7

to restart GDM then restart your system. It should say that in the instructions on how to install. This may not solve your problem but that's how you install the drivers.

One quick suggestion make a backup of your xorg.conf like this.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

Then if you need to restore the original do this.

sudo cp /etc/X11/xorg.conf_backup /etc/X11/xorg.conf

Also it should be:

sudo sh NVIDIA-Linux-x86-185.18.14-pkg1.run

Also if you don't have it already installed install nvidia-settings.

sudo apt-get install nvidia-settings

Then to change your res:

gksu nvidia-settings

adkjoe
July 1st, 2009, 01:43 PM
It's a full HD tv and I should be able to get atleast 1280x768. I'm not sure what the max resolution for the tv is but I know it's higher than 1024. Like I said if I put it on auto it goes to 1368 or something like that and it's half off the screen so thats prob to high. But I would like to get atleast 1280, but it's not an option in the display options...all i have above 1024 is 1168 and when I go to that it says mode not supported and if I go any higher the screen is half off the monitor. Why isn't 1280 available in the options?

lavinog
July 1st, 2009, 10:49 PM
What cable are you using to connect the TV?

adkjoe
July 2nd, 2009, 12:10 AM
a vga cable hooked to a dvi to vga connector.