PDA

View Full Version : [ubuntu] Cannot launch Pulse Audio Volume Control



RD1
June 30th, 2009, 09:06 PM
Whenever I attempt to launch pavucontrol I get a brief flash of the window that immediately disappears.

When launched from cli ....
rodger@Bodhisattva:~$ pavucontrol
E: shm.c: shm_open() failed: No such file or directory
E: memblock.c: Assertion 'b' failed at pulsecore/memblock.c:438, function pa_memblock_acquire(). Aborting.
Aborted


Any ideas?

RD1
July 1st, 2009, 09:31 PM
Anyone?

RD1
July 1st, 2009, 09:54 PM
Ok, no answers yet but I have found, it is related to Firefox. Pulse Volume Control works fine until I run firefox.

RD1
July 1st, 2009, 10:37 PM
Installed Opera to try out .... PAVC works fine with opera running.

Anyone willing to help out?

RD1
July 1st, 2009, 11:58 PM
Hello?

RD1
July 2nd, 2009, 03:54 PM
Good Morning World! Anyone out there?

RD1
July 3rd, 2009, 01:39 AM
Bump in the night....

bear24rw
July 3rd, 2009, 03:31 AM
idk what shm is but maybe you can try installing these packages?

libxcb-shm0
libmpich-shmem1.0gf

RD1
July 3rd, 2009, 02:44 PM
libxcb-shm0 is already installed.

libmpich-shmem1.0gf is not installed but, I doubt it has anything to do with this problem.

I can confirm that there is some kind of conflict with Firefox. If Pulse Volume Control is open and Firefox is launched, PVC will crash. PVC cannot then be successfully launched until after logoff. This does not happen when using Opera which, I believe, uses the same plugins as Firefox.

I have upgraded to Firefox-3.5 with no improvement.

P.S. Thanks for your reply. It didn't resolve the problem but, at least someone is trying. :)

RD1
July 10th, 2009, 04:30 PM
Bump

TKoorn
July 20th, 2009, 12:23 PM
I have a similar problem but I don't have a problem with firefox. My pavucontrol sometimes starts if firefox is running and sometimes it does what you describe. Can't seem to figure out what causes it to sometimes work.
If it works it is great, I can redirect streams to different hardware.

RD1
July 20th, 2009, 01:53 PM
At least, I know I'm not alone. :)

wbee
July 20th, 2009, 04:06 PM
RD 1.

I don't know if you have consulted it yet but if not,use the "search" feature to find markbuntu's thread explaining how to set up Pulse Audio correctly.

Also,if you Google "Pulse Audio Documentation",you will get the developer's page. Linking from that,you will find "the perfect setup".

Ubuntu is a labor of love among many volunteers and I say this not be be overly critical,but the Pulse Audio setup is imperfect.

Mega_Fauna
January 26th, 2010, 12:05 AM
Whenever I attempt to launch pavucontrol I get a brief flash of the window that immediately disappears.

When launched from cli ....
rodger@Bodhisattva:~$ pavucontrol
E: shm.c: shm_open() failed: No such file or directory
E: memblock.c: Assertion 'b' failed at pulsecore/memblock.c:438, function pa_memblock_acquire(). Aborting.
Aborted


Any ideas?


Hi,

I have exactly your problem and having read this thread, I get my stuff to work by closing firefox and using the System Monitor to kill all pulseaudio processes. Then I can restart the Pulse Audio Device Chooser and the Volume Control window will stay open.

Why I have to reset the damn thing every couple of reboots, I've no idea, could be a Skype thing, could be an Jaunty thing (I just upgraded)....