PDA

View Full Version : [ubuntu] x-fi and ALSA



Magick93
June 30th, 2009, 12:09 PM
Hi all

I am trying to get my X-fi card to work with ALSA. I understand this is possible.

Currently I have sound from the card using OSS4 but there is no midi - and I very much need the midi.

I have tried following the instructions at http://www.moobash.com/Blog/?p=611

But this did not solve my problem.

Can anyone else help?

Please note: I am not a linux expert.

cheesepenguins
July 1st, 2009, 01:01 PM
Hi all

I am trying to get my X-fi card to work with ALSA. I understand this is possible.

Currently I have sound from the card using OSS4 but there is no midi - and I very much need the midi.

I have tried following the instructions at http://www.moobash.com/Blog/?p=611

But this did not solve my problem.

Can anyone else help?

Please note: I am not a linux expert.
This is actually my site and guide, I updated it yesterday, try out the alsamixer section I added.

Magick93
July 1st, 2009, 03:51 PM
Hi

Thanks for your tutorial, and for updating it.

I tried running the alsamixer and this is what I get:
alsamixer: function snd_ctl_open failed for default: No such device or address


Any further ideas?

Cheers

cheesepenguins
July 1st, 2009, 04:35 PM
Hi

Thanks for your tutorial, and for updating it.

I tried running the alsamixer and this is what I get:
alsamixer: function snd_ctl_open failed for default: No such device or address


Any further ideas?

Cheers

There is a app called "Multimedia System Selector", you have to enable it to appear on the main menu (right click, edit Menus), its under the Preferences pane.

Make sure ALSA is selected as default.

If it was already ALSA and no card is detected I would reinstall ALSA as though it was a fresh install of Ubuntu, then following my guide again.

I'm sorry I can't be much more use, I'm a bit of a nab when it comes to how Linux works.

Magick93
July 1st, 2009, 05:19 PM
Thanks cheesepenguins

I tried that, but still no joy.

I've trying to get my computer to play nicely with my X-fi card for about a month now. I can get sound using OSS but not midi.

I'm seriously considering just buying a copy of windows - I hate to admit defeat but this is just too frustrating.

cheesepenguins
July 2nd, 2009, 02:50 PM
Thanks cheesepenguins

I tried that, but still no joy.

I've trying to get my computer to play nicely with my X-fi card for about a month now. I can get sound using OSS but not midi.

I'm seriously considering just buying a copy of windows - I hate to admit defeat but this is just too frustrating.
Nobody ever wants to hear this, but try a fresh install of Ubuntu with the drivers? On a different partition to test?