View Full Version : [ubuntu] Grub Loading Error 21

June 29th, 2009, 09:15 PM
I have just installed Ubunto and can't boot up my system because of the above error. I have had a look at this forum and found something that seems to reinstall the grubs, but that didn't work.

Thanks for any help,


June 29th, 2009, 09:27 PM
Boot from live cd, open a terminal and post results of:

sudo fdisk -l

Also, you can try supergrub:


June 29th, 2009, 09:57 PM
Here is the results:

Unable to seek on /dev/sda

June 29th, 2009, 11:25 PM
It would seem that your installation did not go successfully. The sudo fdisk -l command run in a terminal window would have showed the partitions on sda, which is your hdd. If it did not, then clearly something is wrong.

If you do have important data, then you might try reinstalling. But first do a checksum on your downloaded .iso, and check the cd for errors at the opening menu.


Also, just to be sure, the l is a lowercase L in sudo fdisk -l. ALso, do have more than one hdd?

June 30th, 2009, 12:20 AM
I have tried to open the md5sum file, but nothing happens. I have tried reinstalling, but the same problem happens.

I have 2 raid 0 disks and setup some partitions when installing, but I couldn't setup us NFTS system, whihc were shown in the screenshots. Do you think this is related or some other problem?

June 30th, 2009, 12:24 AM
The problems may be related to your raid setup. Search for the topic in this forum and at google.

June 30th, 2009, 02:03 AM
If you used the standard live cd to install, the odds are that you trashed the raid0 set. Raid recognition is not built into the live cd version of the installation disks. In that case the partition editor only shows the individual disks as unallocated space. You would need to use an alternate cd to install.

June 30th, 2009, 07:10 PM
I have been looking at this site trying to work out which is the correct version for me and ain't got a clue!!! Please could you tell me which version to get with raid drives, intel inside and a desktop...

I do see what you mean about not recognising my disks, but I haven't managed to get it booted up since I installed it, so probably lucky for me!! Hoping this new version will sort out my boot up problems too...



June 30th, 2009, 08:26 PM
Get the alternate cd from the same site you downloaded the live cd from. If nothing else it will tell you the status of your raid set. If what I suspect is true you will have to reinstal everything formally in the set from scratch. At least if you still want to use the disks as a raid0 you will be able to restore the integrity of the raid set, repartion it, and reinstall everything (both for windows and ubuntu). You should read the following site to install ubuntu to a raid: https://help.ubuntu.com/community/FakeRaidHowto