PDA

View Full Version : [ubuntu] How to solve "The following packages cannot be authenticated"



StephenChan
June 29th, 2009, 04:09 AM
Hi everyone, I have established a local repository on my machine, and built a debian package and signed it , then I put the debian package I built onto the local repository, after I run "sudo apt-get install mydebpackage”, there is a warning presented " The following packages cannot be authenticated", I have uploaded my public key to key server and import the key into my key repository, but the warning is still here. Could anyone tell me how to solve this problem?

I saw somebody wrote "Ideally each package should be signed by somebody who is trusted by the Debian or Ubuntu people. That package should then be verified and re-signed by somebody from Debian or Ubuntu", Is that true? Should my package be re-sign by someone from Debian or Ubuntu ?

Any idea is appreciated!