PDA

View Full Version : [ubuntu] 9.04 GRUB Error 17 - Computer suddenly stopped booting - please help



kashifmehmood
June 28th, 2009, 09:11 AM
Hi,

I have ubuntu 9.04 installed on a Dell Inspiron 6400. It has been working fine for the past couple of months. Suddenly, I was unable to boot with a GRUB Error 17 message.

I was not trying to partition the disk or anything like that. Just normal usage like web, video etc. I do not have dual boot.

I don't want to format the disk and lose all of my data. I do not have Vista dual boot. Just a simple ubuntu 9.04 installation.

Any help would be highly appreciated. Many thanks in advance.

desperado665
June 28th, 2009, 09:23 AM
Is it possible you have a connected external drive? Disconnect drive and boot again. Error 17 indicates the partition that grub expects to find your Linux installation has changed to a different partition. It may also be possible that you had installed with an external partition mounted which is no longer there.

Elfy
June 28th, 2009, 09:52 AM
Boot with the livecd.

From a terminal run
sudo fdisk -l to find your linux partition number, use the number in the mount command instead of sdxy


sudo mkdir /mnt/tmp
sudo mount -t ext3 /dev/sdxy /mnt/tmp

Now run
ls -al /dev/disk/by-uuid

Note the UUID for your partition, check it against the menu list.


cat /mnt/tmp/boot/grub/menu.lst

rraj.be
June 28th, 2009, 09:53 AM
Try to reinstall your GRUB from Live CD.

kashifmehmood
June 28th, 2009, 12:02 PM
Hi there,

Thanks for your responses. I not sure how to go to terminal from the LiveCD. Should I select the option "Try Ubuntu without installing"?

THe liveCD is also not working for me, so I will try the alternative CD. Many thanks.

Elfy
June 28th, 2009, 12:06 PM
yes you need the try without installing option

you won;t be able to accomplish the same things with the alternate cd

if you can't get the livecd to work I would look at why that is first, if not you could try using supergrub - http://www.supergrubdisk.org/

Efros
June 28th, 2009, 12:47 PM
I have seen this with a USB mounted drive being left in during a reboot on some motherboards, Hard Drives and Flash Drives. Seems some motherboard BIOSs rejig the HD priority/organization if a drive is added prior to the current boot, bloody annoying.

kashifmehmood
June 28th, 2009, 08:29 PM
Thanks for taking the time and helping me out everyone.

There is no external mounted partition. No USB installation or whatsoever. Just a simple laptop with an internal HDD which was working fine until one day. :-(

The liveCD is not working and Supergrub is not making any sense to me. A shame that the alternate CD cannot be used for this purpose.

LewRockwell
June 28th, 2009, 08:41 PM
Thanks for taking the time and helping me out everyone.

There is no external mounted partition. No USB installation or whatsoever. Just a simple laptop with an internal HDD which was working fine until one day. :-(

The liveCD is not working and Supergrub is not making any sense to me. A shame that the alternate CD cannot be used for this purpose.

supergrub does take some learning since it has both automatic and manual utilities

it sounds to me like your optical drive isn't set to boot before your hard drive

you can either fix this in your BIOS or you can start the machine and depress F12 about twice per second to get to the boot device selection area

both the liveCD and supergrub should be able to correct your problem

I use the supergrub since it's easier once you know how to use it

.

gjoellee
June 28th, 2009, 08:41 PM
Sometimes you just have to change your HDD's boot priority in your computers BIOS.

Son of William
June 28th, 2009, 08:41 PM
This may be an issue with more than just grub. You may be having a problem with your hard drive. Unfortunately that expands the scope of troubleshooting

A 6400 Inspiron is starting to get up there in age. Have you replaced the original hard drive?

You say the Live CD is not working for you. Have you tried enabling boot from CD in your bios? That may do the trick for you.

kashifmehmood
June 28th, 2009, 09:17 PM
Hi there

There is no problem with the Boot priority in the BIOS. The liveCD boots fine but none of the options work. The alternate CD is able to work but I don't want to lose my ubuntu installation.


I have managed to install SuperGrub on a bootable CD and tried it out. The option.

GRUB=> MBR & !LINUX! (1) Auto

Does not work. It gives an Error 15. File not found.

I have tried the path using "Choose Language & Help" but it gives the same error (Error 15).

Thanks again everyone.

LewRockwell
June 28th, 2009, 09:23 PM
it's strange that the liveCD isn't working properly

almost makes me think you've got motherboard level problems

did it overheat recently?

have you tried the memtest option on the liveCD?

keep us posted!

.

Son of William
June 28th, 2009, 10:01 PM
Try downloading a new Live CD image. That way you can rule out a flawed disc being the issue.

kashifmehmood
June 28th, 2009, 10:08 PM
Hello,

The checksum test for the LiveCD passes. I have also done a BIOS test in the laptop and that also reports no problems.

Anybody has any ideas about SuperGrub error 15 message?

gfk
June 28th, 2009, 10:44 PM
Try these instructions to reinstalling grub


If you've installed GRUB into the Root Partition instead of the MBR, the commands are a little different. Here's are the instructions that I have for my system:

How to Restore the Grub Menu after a Re-Ghosting:

1. Boot from a Live CD, like Ubuntu Live, Knoppix, Mepis, or similar.

2. Open a Terminal. Go SuperUser (that is, type "su"). Enter root passwords as necessary.

3. Type "grub" which makes a GRUB prompt appear.

4. Type "find /boot/grub/stage1". You'll get a response like "(hd0)" or in my case "(hd0,3)". Use whatever your computer spits out for the following lines.

5. Type "root (hd0,3)".

6. Type "setup (hd0,3)". This is key. Other instructions say to use "(hd0)", and that's fine if you want to write GRUB to the MBR. If you want to write it to your linux root partition, then you want the number after the comma, such as "(hd0,3)".

7. Type "quit".

8. Restart the system. Remove the bootable CD.

kashifmehmood
June 28th, 2009, 11:30 PM
Hello,

downloaded 9.04 again and burned another livecd. This time, it worked and managed to boot into ubuntu. Went into the terminal and followed the instructions given by forestpixie (http://ubuntuforums.org/member.php?u=610428)

Here is the output

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x38000000

Device Boot Start End Blocks Id System
/dev/sda1 * 14333 14594 2096128 c W95 FAT32 (LBA)
/dev/sda2 13996 14593 4803435 5 Extended
/dev/sda5 13996 14593 4803403+ 82 Linux swap / Solaris

Partition table entries are not in disk order

Command 2: Create the tmp directory. Done

Command 3: It was not working as the filetype was not ext3 but Fat32. I replaced it with vfat and the command worked. The output after that is given below:

ubuntu@ubuntu:~$ sudo mount -t vfat /dev/sda1 /mnt/tmp
ubuntu@ubuntu:~$ ls -a1 /dev/disk/by-uuid
.
..
4CFE-CA3A
ee337a29-9afe-4df5-86b6-26b899190e7e
ubuntu@ubuntu:~$ cat/mnt/tmp/boot/grub/menu.1st
bash: cat/mnt/tmp/boot/grub/menu.1st: No such file or directory

Can somebody please advise how to proceed further?

Regarding the suggestion by gfk (http://ubuntuforums.org/member.php?u=220376) to reinstall the grub, Here is the output:

grub> find /boot/grub/stage1

Error 15: File not found

Please find below the output from sudo mount command if that helps:

ubuntu@ubuntu:~$ sudo mount
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=0755)
tmpfs on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=0755)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
/dev/sr0 on /cdrom type iso9660 (ro,noatime)
/dev/loop0 on /rofs type squashfs (ro,noatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)
/dev/sda1 on /mnt/tmp type vfat (rw)

From another thread, tried another command which is below:

ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt
ubuntu@ubuntu:~$ ls /mnt
boot.ini MD2Fixer.Log ntldr WERUNTIME.INI
bootmgr md3.txt pagefile.sys windows
Documents and Settings mdt Program Files
hiberfil.sys ntdetect.com rmbr.exe

Why do I have a windows and program files folder? Ubuntu was a fresh installation (the disk was formatted).

Guys, please help. Many thanks.

Elfy
June 29th, 2009, 03:47 PM
ubuntu@ubuntu:~$ ls -a1 /dev/disk/by-uuid
bash: cat/mnt/tmp/boot/grub/menu.1st

First off - the 1's here should be lower case L.

It doesn;'t appear that you have ubuntu installed - unless it's a wubi install - that is installed inside windows and appears in windows add/remove thing.

Can you follow this post - http://ubuntuforums.org/showpost.php?p=7253088&postcount=3

When you have your results txt file post it here.

kashifmehmood
June 30th, 2009, 10:21 PM
Hi there

I know it sounds crazy but I had no Windows installed. Only ubuntu. Installed direct from the CD, by formatting the HD. It is surely the most strangest situation I have encountered.

Output from the script. Many thanks again everyone.

============================= Boot Info Summary: ==============================

=> Grub0.97 is installed in the MBR of /dev/sda and looks on the same drive
in partition #1 for /boot/grub/stage2 and /boot/grub/menu.lst.

sda1: __________________________________________________ _______________________

File system: vfat
Boot sector type: Vista: Fat 32
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows XP
Boot files/dirs: /boot.ini /BOOT.INI /bootmgr /BOOTMGR /ntldr /NTLDR
/NTDETECT.COM /ntdetect.com

sda2: __________________________________________________ _______________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sda5: __________________________________________________ _______________________

File system: swap
Boot sector type: -
Boot sector info:

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ __________________________________________________ ___

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x38000000

Partition Boot Start End Size Id System

/dev/sda1 * 230,246,400 234,438,655 4,192,256 c W95 FAT32 (LBA)
/dev/sda2 224,829,675 234,436,544 9,606,870 5 Extended
/dev/sda5 224,829,738 234,436,544 9,606,807 82 Linux swap / Solaris

/dev/sda1 overlaps with /dev/sda2
/dev/sda1 overlaps with /dev/sda5

blkid -c /dev/null: __________________________________________________ __________

/dev/loop0: TYPE="squashfs"
/dev/sda1: LABEL="MEDIADIRECT" UUID="4CFE-CA3A" TYPE="vfat"
/dev/sda5: UUID="ee337a29-9afe-4df5-86b6-26b899190e7e" TYPE="swap"

=============================== "mount" output: ===============================

proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=0755)
tmpfs on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=0755)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
rootfs on / type rootfs (rw)
/dev/sr0 on /cdrom type iso9660 (ro,noatime)
/dev/loop0 on /rofs type squashfs (ro,noatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)


================================ sda1/boot.ini: ================================

[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Embedded" /fastdetect /KERNEL=NTOSBOOT.EXE /maxmem=768

================================ sda1/BOOT.INI: ================================

[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Embedded" /fastdetect /KERNEL=NTOSBOOT.EXE /maxmem=768