View Full Version : [ubuntu] Package upgrade problem

June 28th, 2009, 08:36 AM
Hi all,

I've got a problem after an upgrade this afternoon. I don't blame it on ubuntu but need help to fix it all the same!

I get an error coming up, please see the screenshot attached for details.

When I do as it says and run sudo apt-get check, or upgrade I get this error:

Reading package lists... Done
Bus errordependency tree... 0%

Also some applications don't seem to start up which is a worry.

I blame all this on Vista.

I had a dual boot with it setup for study and when it died for about the 3rd time it seemed to damage my 2nd internal sata drive.

It wouldn't show up in windows for formatting etc, so I salvaged some files from it via trusty Jaunty.

I'm pretty sure one or two folders got trashed though as the copy/paste slowed up drastically when it got to them and that's when I was also performing a routine ubuntu upgrade...

Long back story - hope it helps to understand what's going on here.

Thanks in advance

June 28th, 2009, 11:01 AM
Just wanted to say I resolved this issue by unchecking source code as a software source, as outlined here;


I also changed the server to main from my locale though I doubt that had much to do with it. In fact I've switched it back to my location just now and will report back if there's any further problems.

Otherwise consider it solved.... to think I had missing menus/apps not loading and more and that fixed it all!