PDA

View Full Version : [ubuntu] Xorg.conf Edits Do Not Change Screen Res



trelichiban
June 27th, 2009, 06:05 AM
This is wildly frustrating. Please help me before I throw my monitor out the window.

I installed Jaunty a few hours ago and have yet to change my Acer AL2016W to its native resolution of 1680x1050. I have used community video drivers and the Nvidia drivers. I have edited xorg.conf several dozen times, adding the correct resolution under Screen/Display/Modes. This has changed nothing.

Could the OS be failing to recognize the screen? Here's the current conf:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerFlags"
Option "DontZap" "false"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -HSync +Vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Modes "1680x1050"
EndSubSection
EndSection

trelichiban
June 27th, 2009, 08:33 AM
I've found several threads from people in similar scenarios, mainly related to an arbitrary resolution limitation on a second monitor, and I'm ready to start blaming the EDID. Nvidia seems to disregard xorg.conf identifiers and even calls my LCD a CRT. I've tried to use the global variable and the three smaller variables - but no luck. I just don't get it.

Currently selectable resolutions start at 1360x768 and 1152x864 and go down.

The most frustrating thing about this is how Gutsy runs the native resolution Live.

Updated xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
Option "DontZap" "False"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "yes"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "AL2016W"
VendorName "Acer"
ModelName "AL2016W"
Option "UseEDID" "FALSE"
EndSection

Section "Device"
Identifier "7600GT"
Driver "nvidia"
# Option "RandRRotation" "on"
Option "Rotate" "right"


EndSection

Section "Screen"
Identifier "Default Screen"
Device "7600GT"
Monitor "AL2016W"
Option "UseEDIDFreqs" "FALSE"
Option "UseEDIDDpi" "FALSE"
Option "ModeValidation" "NoEdidModes"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1200" "1440x1440" "1400x1050" "1360x850" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

tolotos
June 27th, 2009, 09:12 AM
Not all resolutions are available to the standard xserver. To force certain resolutions and refresh rates you can use modlines (http://wiki.ubuntuusers.de/XServer_Modelines). There are also some Modline-Generators on the web, just google for them. In any way you have to know the specifications of your monitor (Your monitor manuel should contain them). But be careful. In my case severel tries (more then 10!) were necessary to get the x-server to do what I want him to. So don`t stop to keep trying, different modline-generators ;-)..
(Eventually you could also try to get the gutsy xorg.conf and replace your current config with it.)
Hope that helps.

trelichiban
June 27th, 2009, 08:14 PM
I had tried a modeline before and adding it to the current config has not helped. I found a bug entry at https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/6096 with a similar complaint, and even after pasting the modeline that worked for that particular user, I am staring at the wrong resolution.

I loaded up Gutsy Live and noticed that the xorg.conf shows the GPU running the nv driver. I'll give that a try. The following conf didn't help any.


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "DontZap" "False"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "yes"
Option "ZAxisMapping" "4 5"
# generated from default
EndSection

Section "Monitor"
Identifier "AL2016W"
VendorName "Acer"
ModelName "AL2016W"
Option "UseEDID" "FALSE"
Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -HSync +Vsync
EndSection

Section "Device"
Identifier "7600GT"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "7600GT"
Monitor "AL2016W"
DefaultDepth 24
Option "UseEDIDFreqs" "FALSE"
Option "UseEDIDDpi" "FALSE"
Option "ModeValidation" "NoEdidModes"
Option "Rotate" "right"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
# Option "RandRRotation" "on"
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1200" "1440x1440" "1400x1050" "1360x850" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

CatKiller
June 28th, 2009, 01:31 AM
I saw that you've told X not to use EDID values, but I've not seen anywhere that you've told X which frequencies to use instead. HorizSync and VertRefresh values go in the Monitor section. According to the "driver" that I found on Acer's website, the ranges for your monitor are 31.5-84 and 56-86.

Don't forget that information about the mode selection process will be logged at /var/log/Xorg.0.log. You can get more information in there by using
Option "ModeDebug" "True" in the Device section.

trelichiban
June 28th, 2009, 03:24 AM
I'm in a good place right now. X has started using the native resolution, but two major problems have popped up. The refresh rate is obviously set incorrectly (I've got fuzziness/snow) and the screen space is actually a good distance wider than it should be. This doesn't display until my mouse moves to the side of the screen, but when it does, the viewable area pans to include a big black unusable bar.

I'm close, but I can't find an actual spec sheet for this model and thus can't find what the proper settings are.

Update: I've fixed the fuzziness by setting the Refresh Rate at 60, but the extra unusable space won't go away.

CatKiller
June 28th, 2009, 11:59 AM
Are you using a virtual resolution? That gives the pan-and-scan behaviour you describe if the virtual resolution is higher than the physical resolution.

trelichiban
June 28th, 2009, 09:00 PM
Are you using a virtual resolution? That gives the pan-and-scan behaviour you describe if the virtual resolution is higher than the physical resolution.

If I am, then I'm not doing it on purpose.

The usable space (where the desktop is drawn and where windows can be dragged) is limited to 1680x1050. However, the mouse can move into an extra black space on only one side of the screen. I'm guessing that it's maybe 400-500 pixels wide.