PDA

View Full Version : [ubuntu] Totem doesn't play .avi, others do



Vostrocity
June 27th, 2009, 02:02 AM
I like Totem the best out of all the media players, but for some reason it won't play my .avi videos. It says I need to install plugins, goes searching for one, says it can't find any, and then just plays the sound but not the picture. VLC and Xine both work perfectly but I don't like their interface much. MPlayer gives a warning about unknown codec but plays it anyway just fine.

philcamlin
June 27th, 2009, 02:03 AM
hmm why dont you just use vlc or something :popcorn:

Vostrocity
June 27th, 2009, 02:06 AM
Because I prefer Totem's interface, and that it generates video thumbnails.

philcamlin
June 27th, 2009, 02:07 AM
hmm mine finds the plugins

try it again

Vostrocity
June 27th, 2009, 02:14 AM
No luck but I'm pretty sure avi was supposed to be supported by default.

philcamlin
June 27th, 2009, 02:19 AM
sudo apt-get purge totem

sudo apt-get install totem

try that :popcorn:

Vostrocity
June 27th, 2009, 02:21 AM
Gasp you used :popcorn: again.

EDIT: Nope still not working.

EDIT2: I just installed w32codecs from Medibuntu, and it's still not working! Should I uninstall it then?

Vostrocity
July 10th, 2009, 08:59 PM
Bump!

Still haven't solved this. I'm trying to use Cinelerra, but when I import the .avi files it only shows the audio track which is similar to what happens with Totem.

fooman
July 10th, 2009, 09:14 PM
have you tried the "ubuntu-restricted-extras" package? it should be in synaptic, or in a terminal:


sudo apt-get install ubuntu-restricted-extras

i think that will do the trick. ...hope it helps.

Vostrocity
July 11th, 2009, 12:05 AM
I already had that installed.

hansdown
July 11th, 2009, 12:15 AM
Hi Vostrocity.

There are a whole bunch of bug reports for totem.

http://www.google.ca/search?q=.avi+files+in+totem+in+ubuntu+9.04&ie=utf-8&oe=utf-8&aq=t&rls=com.ubuntu:en-US:unofficial&client=firefox-a

Totem-xine "may" work better.

Vostrocity
July 11th, 2009, 08:57 PM
So I guess there isn't much of solution yet. My main problem is getting it to work in Cinelerra since for playback I can just use VLC. But I suspect the two apps have the same issue.