PDA

View Full Version : [ubuntu] Nvidia GeForce MX 440 Only 800x600 Resolution



Johan-Steyn
June 17th, 2009, 09:52 PM
Hi All,

I am struggling with a desktop pc from work that is stuck in low resolution (800x600).

"lspci | grep -i nvidia" reports the following:
02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a4)

I have tried both default and propriety drivers (nvidia-glx-71) with the same result = maximum resolution 800x600.

A have edited xorg "gksu gedit /etc/X11/xorg.conf" and this the output:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:42 PST 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection
The red highlighted area was manually added.

When I restart X server, I'm still stuck at 800x600.

Any Ideas?

Thanks,

JS

TheBuzzSaw
June 17th, 2009, 09:56 PM
Do you have the proper Nvidia driver installed?

If you have the driver, are you familiar with Nvidia's configuration tool?


gksudo nvidia-settings

I've had far better luck configuring things using nvidia-settings than any of GNOME's tools.

Buntuuser01
June 17th, 2009, 10:00 PM
Maybe trying my xorg.conf helps.... But remember to backup your old xorg.conf!!!!!!!!!! I have a GF2 MX440: sort of the same card (bus much slower!). Works fine for me. Have you installed the proprietary Nvidia (classic) drivers?



Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "--> VESA"
ModelName "1280X960@60HZ"
UseModes "Modes[0]"
DisplaySize 305 230
HorizSync 31.0 - 60.0
VertRefresh 50.0 - 60.0
Option "CalcAlgorithm" "XServerPool"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVidia"
BoardName "GeForce2 MX/MX 400"
Option "NoLogo" "true"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "768x576" "640x480"
EndSubSection
EndSection


P.S. I've installed "nvidia-glx-96" which (synaptic says) is also for the GF4 I think....

Johan-Steyn
June 17th, 2009, 10:55 PM
Hi Guys,

Thanks for the advice.

It tried the classic driver and finally it works. However, max resolution is 1024x786.

But hey, who's complaining - at least the 3G works.

Thanks Again,

JS

Buntuuser01
June 18th, 2009, 03:09 PM
Glad it worked :) But it is strange that you cannot get resolution higher than 1024x768. Are you sure you are using the Nvidia driver (not the Mesa driver from Xorg named "nv")? Have you gor the following line in your xorg.conf?

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x600" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "768x576" "640x480"
EndSubSection
EndSection

Have you tried "xrandr"?