PDA

View Full Version : Building the latest rubygems into a debian package



sbtiwari
June 16th, 2009, 08:40 PM
Hi,

This is the first time I am posting here. I am a complete newbie. I am aware its not a Debian Forum, but still, had to start somewhere.

My problem is that when I issue the 'apt-get install rubygems' command, the package that is installed is way too old, the version being 1.2.x. And when I install from source from the rubygems website, the package is the latest.

Is there a way to build the latest rubygems package into a debian package for my own usage?

Any help would be appreciated. I hope I have formed my question correctly.

Thanks!
Swati

InfinityCircuit
June 16th, 2009, 10:24 PM
1.3.1 is in jaunty, 1.3.4 is in karmic. What version of Ubuntu are you running? Are those new enough for you?

mrtomservo
June 16th, 2009, 10:27 PM
http://www.linux.com/archive/articles/60383

Might be a good place to start, good luck!

sbtiwari
June 16th, 2009, 11:58 PM
Hi,

Thanks for the help, but the above article assumed that the program that I am trying to build comes with a ./configure script.

I am trying to build rubygems into a package, the source of which does not come with a configure script. It comes with a ruby script.

Has anyone built rubygems 1.3.4 into a debian package or a package that does not come with a ./configure script?

Thanks for all the help,
Swati