PDA

View Full Version : [gnome] Cannot move taskbar on multi-monitor setup



samandiriel
June 15th, 2009, 01:45 PM
I upgraded my install to 9.04 shortly after it was available.

I have two monitors on a Nvidia card using Twinview.

I was quite happy with my taskbars (two of them, one atop the other) on my left hand monitor along the top.

A power failure took out my machine. Upon reboot, my taskbars are now on the right hand side instead of the left.

Trying to drag either taskbar using an icon-free area doesn't work.

Checked gnome-conf, and “apps” > “panel” > “global” key “locked_down” is unchecked.

Can anyone please help with this issue? I'm massively stuck...

PureLoneWolf
June 15th, 2009, 07:25 PM
Try holding down the ALT key before you click and drag...keep it held down through the drag.

In gconf-editor, you can specify the monitor for each of the panels, not just if it is locked. I personally prefer to use ALT

samandiriel
June 15th, 2009, 07:31 PM
Try holding down the ALT key before you click and drag...keep it held down through the drag.

In gconf-editor, you can specify the monitor for each of the panels, not just if it is locked. I personally prefer to use ALT
Nope, no change. The bars still don't move, either one of them.

Uubnewb
June 15th, 2009, 07:52 PM
I'm not sure if it will work (it's a long shot to say the least) but try to right-click on the actual taskbar and click on the "Allow this Panel to be Moved" button. It shouldn't make a difference since you allready set it in the gconf-editor, but maybe the sudden power failure messed with the settings.

samandiriel
June 15th, 2009, 08:02 PM
I'm not sure if it will work (it's a long shot to say the least) but try to right-click on the actual taskbar and click on the "Allow this Panel to be Moved" button. It shouldn't make a difference since you allready set it in the gconf-editor, but maybe the sudden power failure messed with the settings.
There is no "Allow this Panel to be Moved" button. ON right click there is add to panel, properties, delete this panel, new panel, help, about panels

Uubnewb
June 17th, 2009, 04:46 PM
Oh, sorry, I was thinking about Ubuntu 8.10. Did you try the following (https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/264): Right-click on the panel; click properties; uncheck the expand button. The bar will get smaller and little handles should appear.

sgrahovac
June 19th, 2009, 10:37 PM
The holding the ALT key before dragging the panel trick worked for me. Thanks!

ozindfw
August 4th, 2009, 02:28 PM
The ALT key had no effect for me (in 9.04) What worked was turning off the expand option (checkbox in Properties|General) I could then move the taskbar as expected. I wanted it on the second monitor. It great. I added the window list applet and now the tool bars show the windows active for each monitor.

Oz (in DFW)

samandiriel
August 4th, 2009, 02:37 PM
The ALT key had no effect for me (in 9.04) What worked was turning off the expand option (checkbox in Properties|General) I could then move the taskbar as expected. I wanted it on the second monitor. It great. I added the window list applet and now the tool bars show the windows active for each monitor.

Oz (in DFW)
YOU, sir, ARE A ROCKSTAR! I can't thank you enough for your workaround, I am very glad you posted to my old old old thread. My taskbar is now where God intended it to be!

trspencer
January 22nd, 2010, 03:35 AM
holding down ALT did the trick...thanks very much for the tip.

mister_playboy
January 28th, 2010, 11:42 PM
Thanks for the fix... I was trying to figure this out.

swapz83
February 2nd, 2010, 12:59 PM
ALT key + panel drag worked perfectly. Thanks!

cool675
January 4th, 2012, 08:08 PM
Um Hello everyone found this thread googling about the same issue in fedora 16, ALt+right mouse key enabled me to set the position of the panels. no way about dragging them, though. big thanks nevertheless. ps had tried some time on this had used gconfig-editor before to enable "toolbar-detachable" but no sure whether that has any effect at all...bye

trallallero
March 15th, 2012, 11:48 AM
Thanks, I was also trying to figure this out.
The trick was just "right click->add to panel->window list".

jnankin
October 15th, 2012, 05:10 PM
On 12.04 to get the context menu or to move the taskbar on my machine you need to hold down both ALT and the windows key.