PDA

View Full Version : [ubuntu] Sound not working in Firefox after mplayer install



snakeman21
June 14th, 2009, 06:03 PM
I'm running Ubuntu 9.04 on an Acer Aspire One. So far, it's worked wonderfully. I install 8.10 shortly after I bought the laptop, and recently upgraded. Then, I spent all day tricking out my Desktop so it's pure awesome-ness. Everything still worked smoothly. But then, yesterday, I replaced Totem with MPlayer. Since then, sound does not work in Firefox. Video feed works fine, but sound does not. Instead of playing the sound, it makes a funny little cracking noise. I don't understand why this would be happening, as I didn't actually delete Totem. I just installed MPlayer and set it as the default player for files on my hard drive. I kept Totem because I need it for FLV movies.

And I'm not sure if this has any significance, but when I installed MPlayer, it had the same problem until I switched the sound mixer from ALSA to OSS. After switching to OSS, it worked wonderfully. But I can't seem to find any setting that allows me to do that for Firefox, so I can't make it work. I even tried uninstalling MPlayer and rebooting... Still no luck. Any ideas?