PDA

View Full Version : [ubuntu] Problem w/ Pandora.com



missing in action
June 13th, 2009, 04:15 AM
Hey all.. I don't know what happened, but when I try to use Pandora now it does not load like it used to. It just freezes up and nothing happens. Anyone have the same issue? :-?

lexbarron2007
July 6th, 2009, 05:12 AM
im having the same problem.
when i load pandora.com in firefox it only loads part way and stops. i installed all the drivers firefox suggested for me, now im wondering what drivers are likely to help here.
i dont actually know what drivers pandora should need to be able to run.

crawlerzero
July 8th, 2009, 11:19 PM
I have the same issue with Pandora.

I recently upgraded my machine to 9.04 and now Pandora will not work properly. It loads partially, and around 20% loaded it hangs.

dansar99
July 10th, 2009, 04:37 PM
Pandora does not load for me either. I wish someone could post a fix,if there is one. Dan

dE_logics
July 10th, 2009, 06:28 PM
Appears to be more of a Firefox problem.

You all installed that flash and java plugin for firefox?

Can't try it, I'm outside the US.

bcfieldi
July 6th, 2010, 11:10 AM
Same here, pandora will not load for me. I have java 6u20 and latest flash 10.1 update. Most flash and java works for me fine but pandora will not load the player itself. Opening the javascript console gives me this error.


Failed to load resource
Unsafe JavaScript attempt to access frame with URL http://www.pandora.com/ from frame with URL http://www.facebook.com/extern/login_status.php?api_key=ca44798cf7067942a82579c2c 720f7dd&extern=2&channel=http%3A%2F%2Fwww.pandora.com%2Ffacebook%2F xd_receiver.htm&locale=en_US. Domains, protocols and ports must match.

I've tried re-installs of both java and flash, chrome, firefox, and probably a dozen different fixes to no avail. I'm stumped.

ronnielsen1
July 6th, 2010, 12:08 PM
No problem here with Ubuntu 10.04 and firefox

ronnielsen1
July 6th, 2010, 12:35 PM
You might make sure these aren't installed

In Firefox, make sure to disable add-ons (extensions) like Adblock, Flashblock, or NoScript. These add-ons are not supported for use with Pandora. Also, select Tools -> Options (on a Mac: select Firefox -> Preferences):

Under "Content," make sure "Load images automatically" and "Enable JavaScript" are checked.
Under "Privacy," make sure "Accept cookies from sites" and "Accept third-party cookies" are checked.


http://blog.pandora.com/faq/contents/144.html

bcfieldi
July 6th, 2010, 01:23 PM
Already checked that. I don't use Ad or flashblockers and all java and cookie settings are appropriate. Not the issue. Pandora loads, but the flash player itself is just a blank white square. Same thing happens if I go to adjust the website or global adobe flash settings. Blank square where the flash should be. Probably unsolvable until adobe gets their act together and fixes this with the next update, which may be never... I guess I'll log the issue with them today.

Is this just happening to me or is this what is happening to others not seeing pandora as well?

ronnielsen1
July 7th, 2010, 10:43 AM
Is this just happening to me or is this what is happening to others not seeing pandora as well?
It's working fine on my box with Ubuntu 10.04 and firefox 3.6.6
I assume you have ubuntu-restricted-extras and all codecs etc installed

ronnielsen1
July 7th, 2010, 01:06 PM
I just installed firefox 4 and had no issues either. You might make sure you have all the codecs and everything installed.

http://linuxpoison.blogspot.com/2009/04/multimedia-support-in-ubuntu-904-jaunty.html

bcfieldi
July 12th, 2010, 04:08 PM
Well, my problem has been fixed but I'm not sure what exactly I did to fix it. I think that it might have been conflicting lib files. There is a libgcflashplayer.so file located in /opt and a libflashplayer.so file in /usr and I think that they conflict with each other. If you are using Chrome, click the wrench in the upper right corner then click Options > Under the Hood > Content Settings > Plug-ins > Disable individual plug-ins, then disable the shockwave flash plug-in under the /opt location.

Disabling the same in Firefox should have the same affect. Let me know if this is successful for everyone that was experiencing the problem. If not I'll try and see if there was something else I did that fixed the problem for me.

fireoftroy
October 17th, 2010, 10:01 PM
What's weird for me is that my 10.10 desktop will run Pandora, but my 10.10 laptop will not. Firefox reports the flash plug-in is up to date, so I'm not really sure what is different between the two. If I figure it out, I'll let you know.