View Full Version : [ubuntu] Metacity settings do nothing, not running Compiz

June 12th, 2009, 10:13 PM
I followed the tutorial here:
and the tutorial here:
in order to customize my Metacity. Unfortunately, none of the changes made in gconf-editor seem to have any effect at all.

I'm pretty certain I must be running Metacity, since I'm using an 8.10 Intrepid install, with proprietary drivers disabled. Under gconf-editor, I even went to /desktop/gnome/applications/window_manager, and changed the keys current and default (both of which were originally blank), to have the values /usr/bin/metacity.

However, somehow my keyboard shortcuts and compositing effects aren't enabled.

Can anyone give any advice on how to debug this problem?

June 14th, 2009, 05:38 AM
I've tried to resolve this problem by updating to Jaunty, but the issues still remain. I've even gone into Synaptic and removed Compiz to make sure I'm not using it, and none of my Metacity customizations seem to work.

Could anyone point me in the direction I should look to resolve this?

June 14th, 2009, 06:22 AM
In case anyone else has this problem, I resolved it by entering in the appropriate changes using gconftool-2 from the command line. No idea why gconf-editor gui wasn't doing it, even though it was showing the changes graphically, but this fixed it.