PDA

View Full Version : [ubuntu] Black screen (**yawn**)



Jannes.
June 12th, 2009, 10:07 PM
Hello everyone, i'm noob in ubuntu.

I just installed ubuntu 9.04. What i would do was
Install my Enemy-Territory...
But first i had to install Nvidia drivers. So i took from an ubuntu site (http://ubuntuforums.org/showthread.php?t=5246) the info how to install ET. There they said i had to go to hard drivers. And install the ones who arent installed yet. After two or tree errors i could install it. After reboot i got a black screen.
Tried so many options, read all topics bout this but i understand anything...

Please help me, i need my pc next week...

grtz

gradinaruvasile
June 12th, 2009, 10:11 PM
What is that you did exactly? What video card u have?

Jannes.
June 12th, 2009, 10:14 PM
I just activated one of the two nvidia drivers i got by hard drivers...

then i had to reboot, i did and now i got blackscreen...(can see my mouse and move it etc)
It fails when i try to boot in safe mode, it fails when i normally reboot... and i dont want to lose my files :(

NVIDIA GEFORCE FX 5200

gradinaruvasile
June 12th, 2009, 10:24 PM
Which version drivers did u try?
I suppose u installed them from system->administration->hardware drivers
To restore your graphical interface,boot with recovery mode, choose xfix and then continue boot normally. This will disable the installed drivers though.
Post the driver version.

Jannes.
June 12th, 2009, 10:27 PM
i think it was something with 170...

Mhm can u repeat that all and explain it in steps...

Im beginner xD

Jannes.
June 13th, 2009, 02:23 PM
Maybe solutions are, Reinstall older driver of nvidia, delete the newest one...

BUT HOW?

ItaniKnight
June 14th, 2009, 07:16 PM
The official Nvidia install instructions are here: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia


1. Switch to the console (Try using ctrl+alt+F1, or reboot and select recovery mode from the GRUB menu.)
2. Use your text editor to open /etc/X11/xorg.conf. (try "sudo nano /etc/X11/xorg.conf")
3. Find the line that says Section "Screen"
4. Insert a new line that says Option "UseDisplayDevice" "DFP".
5. Save the file. If you had to restart into recovery mode, type reboot, otherwise restart your display using sudo /etc/init.d/gdm restart.

May or may not work. I have exactly this problem and this solution does nothing for me, but apparently it works for everyone else.

gradinaruvasile
June 14th, 2009, 07:24 PM
Maybe solutions are, Reinstall older driver of nvidia, delete the newest one...

BUT HOW?

open a terminal and type

sudo apt-get remove --purge nvidia-*

sudo dpkg-reconfigure xserver-xorg

reboot

go to the system->administration->Hardware Drivers

select the recommended driver and activate it
reboot

Jannes.
June 14th, 2009, 07:30 PM
mhm in the paper i found they said

the old trick from
sudo dpkg-reconfigure xserver-xorg
isnt anymore for ubuntu 9.04


Im going to try all ur options now.

This paper i found on internet today --> http://sites.google.com/site/computertip/geenbeeld

its in dutch...

Lets try your options

gradinaruvasile
June 14th, 2009, 07:33 PM
That command helped me alot. Maybe the xfix option does the same, but i have more confidence in stuff i type... It creates a new configuration for the X server from ground up.

Jannes.
June 14th, 2009, 07:41 PM
That command helped me alot. Maybe the xfix option does the same, but i have more confidence in stuff i type... It creates a new configuration for the X server from ground up.

still the black screen with my mouse...

Jannes.
June 14th, 2009, 07:46 PM
The official Nvidia install instructions are here: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia



May or may not work. I have exactly this problem and this solution does nothing for me, but apparently it works for everyone else.

this doesnt work because in the sudo nano /etc/x11/xorg.conf there is nothing inside it

gradinaruvasile
June 14th, 2009, 07:52 PM
this doesnt work because in the sudo nano /etc/x11/xorg.conf there is nothing inside it

Thats x should be uppercase:

sudo nano /etc/X11/xorg.conf

What did u do exactly?

Jannes.
June 14th, 2009, 07:55 PM
how do u mean


I did what the other guy posted

Ive got screen again something bout low graphix mode

there was something bout there is already something in use...
yes or no, i did yes and i see my black screen again...

gradinaruvasile
June 14th, 2009, 08:10 PM
Before going on, did u install drivers downloaded from the Nvidia site? Cause those are removed differently.

If not, do the following exactly:

From the beginning:

Step 1

Reboot, chose recovery mode.
Select root terminal.
When u are at the command prompt type:

dpkg-reconfigure xserver-xorg
apt-get remove nvidia*
press ctrl-d
select resume booting

Step 2

Login
go to the System->Administration->Hardware Tabs

U should have a possibility to chose a driver. Select the recommended one. Click activate.
Reboot.

Jannes.
June 14th, 2009, 08:17 PM
Before going on, did u install drivers downloaded from the Nvidia site? Cause those are removed differently.

If not, do the following exactly:

From the beginning:

Step 1

Reboot, chose recovery mode.
Select root terminal.
When u are at the command prompt type:

dpkg-reconfigure xserver-xorg
apt-get remove nvidia*
press ctrl-d
select resume booting



there it finishes...
after resume booting i got my black screen with only the mouse again...

Jannes.
June 15th, 2009, 07:26 PM
Oke what i did was

-> go on the live CD of ubuntu
-> Backup all my files to my external HDD
-> Reinstall ubuntu

And now im on my fresh new ubuntu.

After every update im going to reboot so i can see where the problem is.

U will hear me later with moooree problems...

Thanx for the help and see you later

grtzz