PDA

View Full Version : [ubuntu] Nvidia GeForce 9500 GT Driver Problems



The_Crow33
June 12th, 2009, 04:59 PM
I've searched this thing to death, and found several posts, but no working solutions. Here's the specs...

I'm running the latest version of Ubuntu (I think we are up to 9.10 or so?) x86_64 bit version. I upgrade the thing daily, so all the packages are up to date as of yesterday.

I have been running an ATI Radeon 9800 SE video card in for a couple years, which took long enough to find a solution to the correct configuration. I just got a new video card, because that one is almost dead. As mentioned it is a Nvidia GeForce 9500 GT, not PCIe but regular PCI slot.

So first I went directly to the Nvidia website and downloaded the correct driver, and follow their instructions to install it. Rebooted, and I'm stuck in a 600x480 resolution. I'm running this on a 19" LCD so yeah it looks awful. It appears that the driver has installed, as I can run nvidia-xconfig, which doesn't help, and I can use the Nvidia Display Configuration tool instead of the Ubuntu one. However, changing the display resolution in the Nvidia Display Configuration Utility only makes my screen scrollable, so that it's like I'm zoomed in on a 600x480 portion of the screen.

I tried modifying my xorg.config file by adding Mode "1280x1024" in the same place I needed to modify the previous one for my ATI card. (Can't remember which section that was, maybe Display?). That didn't help. So I tried removing the driver and installing the latest one in Synaptic (named something like nvidia-glx-180, or something similar). Same problem, so again I removed the package and installed it through the proprietary hardware drivers manager. No help there either. Can anyone help find a solution?

overdrank
June 12th, 2009, 05:55 PM
Could you post your xorg please
cat /etc/X11/xorg.conf
Also which version 9.04 or 9.10 as 9.10 is still beta?

The_Crow33
June 12th, 2009, 07:10 PM
Thank you for your reply. I was trying to use the xorg.conf file created by running the command 'nvidia-xconfig', and I modified it slightly, but it had no effect. Here it is:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder62) Tue Mar 24 06:15:32 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


At one point I modified the Screen Section to look like this...


Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

The_Crow33
June 12th, 2009, 07:36 PM
sorry, forgot to answer the other question... I believe it's 9.04, because I do not have it set to download or install any preleased or unsupported software packages. Only the official packages and security releases.

The_Crow33
June 13th, 2009, 01:15 AM
*bump*
Any ideas would be greatly appreciated.

overdrank
June 13th, 2009, 02:55 AM
*bump*
Any ideas would be greatly appreciated.

Hi and have you tried to install the nvidia driver manually?
You may look at the 185.XX nvidia driver here (http://ubuntuforums.org/showthread.php?t=1125400&highlight=nvidia+185)

The_Crow33
June 13th, 2009, 05:00 AM
Yeah, I tried manually installing the driver from Nvidia's website. I tried the stable version first, no luck. Then I just followed that link you sent to a 'T', but no luck there either. No errors when starting X now, I checked the logs and nothing. No errors of any sort. I did notice that if I uninstall the nvidia display configuration utility and attempt to change my resolution using the ubuntu display utility, it warns that my monitor is unknown. Is there any chance that it is my monitor that is the problem, and not the video drivers?

Arup
June 13th, 2009, 08:05 AM
Just a silly question, did you --purge remove the previous ATI drivers? Also do a total unistall of any installed nvidia or ati modaliases and linux restricted modules and linux restricted modules common.

The_Crow33
June 13th, 2009, 11:02 PM
Thanks for the help. After the first fail, that occured to me as well. So I completely removed any and all video drivers I could find and retried. Still no luck with that. Then after reading the nvidia guide to setup on linux, I noticed a few more packages such as the linux restricted modules and so on that needed to be removed, and a few that needed to be added (linux kernel source). None of that seems to help. Any other ideas?

tekniche
June 26th, 2009, 07:04 AM
Same issue here. I am running the exact same video card (Nvidia 9500 GT). My screen res is a little different though. I'm at 1280*720 on a monitor that does 1920*1080. I have no idea what the issue is. I am able to install the latest version of the nvidia driver and then i can change my screen res to 1920*1080... but the panels and menus are all pushed off the screen. I have tried to modify my xorg.conf but the changes have made no difference. I have also tried configuring the monitor but the settings on the monitor do not change the display at all. I have also tried previous versions of the proprietary nvidia drivers and none work without the latest. Any versions before the most current put me in low graphics mode. I am running out of ideas...

Hey GURUS---- HELP MEH!

rplogue
November 4th, 2009, 10:18 PM
I am having a similar problem when I installed 9.04 it didn't have the driver installed and had the following xorg.conf file

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


if I install the driver from the repository I get the following xorg.conf

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

and similar if I install the latest from the nvidia website.

Only the default (first) config file works ie lets me see the x display though my graphic capabilities are restricted obviosuly. When I restart after installing the correct driver I can never get a x display so I can't see the log in page all I get is a blank screen. I then have to go into recovery mode and go back to the default settings.

Does anybody know how I can fix this to get my graphics card working correctly?

I am using 64 bit ubuntu 9.04 with

graphics card - nvidia GeForce 9500 GT
4GB Ram
Quad Core AMD Phenom(ym) 9550 Processor


I know, after searching around the net, that problems like this are similar but I have yet to find a solution.

Thanks.

m42h31
December 4th, 2009, 10:40 PM
i have similar problem too... compiz not work..

j0mpa
January 18th, 2010, 11:22 PM
I have a problem to.
When i install ubuntu 9.10 x64 and download nvidia 1.95 from nvidias hompage and i install it evrything goes fine until i reboot. When ubuntu starts X the the computer freezes for a while and comes back for some seconds and do the same thing over and over again. If i go to console mode whit ctrl + alt + f2 i cant see what i type and the computer works slow.
I've been searching every where but cant seem to find a solution so now iam back in windows.
Please help me cant stand this operating system.

llawwehttam
January 18th, 2010, 11:25 PM
I don't have a fix as I have never had a problem with Nvidia's drivers but before buying a card I always check out the compatibility list. Its always a good idea.

j0mpa
January 18th, 2010, 11:30 PM
Well in Nvidias driver list the geforce 9500GT is listed so it should work under linux.

llawwehttam
January 18th, 2010, 11:34 PM
Well in Nvidias driver list the geforce 9500GT is listed so it should work under linux.

I really meant this page: https://help.ubuntu.com/community/RecommendedHardware

j0mpa
January 18th, 2010, 11:37 PM
I really meant this page: https://help.ubuntu.com/community/RecommendedHardware

Yeah well i dont have that but should that stop me from using linux or beg for help ? iam sure its more users out there whit non supported hardware and got it to work.

llawwehttam
January 18th, 2010, 11:38 PM
Yeah well i dont have that but should that stop me from using linux or beg for help ? iam sure its more users out there whit non supported hardware and got it to work.

I'm not saying you won't get it to work. I'm just recommending you check the list in the future as it is much easier.

rnestor
January 19th, 2010, 02:28 AM
Check the output in the /var/log/Xorg.0.log file. If the card has multiple connections (DVI and VGA) you'll probably find that X11 is assuming all your xorg.conf settings apply to the VGA0 connection but is finding the monitor connected to the VGA2 port. The solution is to set up your xorg.conf file to map to "Monitor-VGA2". I had the same problem with the Nvidia GeForce 8500GT under 8.xx, 9.04, 9.10 and OpenSUSE. The Nvidia driver doesn't solve the problem, but setting up the right xorg.conf file did in all cases and works with the standard drivers in Ubuntu.

j0mpa
January 19th, 2010, 02:49 PM
Check the output in the /var/log/Xorg.0.log file. If the card has multiple connections (DVI and VGA) you'll probably find that X11 is assuming all your xorg.conf settings apply to the VGA0 connection but is finding the monitor connected to the VGA2 port. The solution is to set up your xorg.conf file to map to "Monitor-VGA2". I had the same problem with the Nvidia GeForce 8500GT under 8.xx, 9.04, 9.10 and OpenSUSE. The Nvidia driver doesn't solve the problem, but setting up the right xorg.conf file did in all cases and works with the standard drivers in Ubuntu.

Oh its like that.
Thx that helped me alot.
would it be possible to get to look at your xorg.conf as a little help in the way?
Anyway thx for the help i really appreciated :)

j0mpa
January 19th, 2010, 08:46 PM
Check the output in the /var/log/Xorg.0.log file. If the card has multiple connections (DVI and VGA) you'll probably find that X11 is assuming all your xorg.conf settings apply to the VGA0 connection but is finding the monitor connected to the VGA2 port. The solution is to set up your xorg.conf file to map to "Monitor-VGA2". I had the same problem with the Nvidia GeForce 8500GT under 8.xx, 9.04, 9.10 and OpenSUSE. The Nvidia driver doesn't solve the problem, but setting up the right xorg.conf file did in all cases and works with the standard drivers in Ubuntu.

Well i did that and it dident help a thing iam stuck again

rnestor
January 20th, 2010, 01:35 AM
Well i did that and it dident help a thing iam stuck again

Two things you need to verify. One, make sure that your Xorg.0.log file shows that X11 is using the setups in your xorg.conf file. Look for the lines that say something like "Output xxx connected" or "Output xxx disconnected" where "xxx" is the Monitor port. On my 8500GT this showed it using VGA2, on my 210 it shows using "VGA0". This, prefixed with "Monitor-" will be the Option in the Device Section. So if your log file shows it is connecting on say VGA7, then your Device Section should have an Option line mapping Monitor-VGA7 to the named Monitor you defined in the Screen section. (Clear, right?) Anyway, take a look at my example to see how the various sections of the file are connected by names.

Second, if there's an error in the file indicating that the resolution you want isn't available because the size exceeds the vertical or horizontal limits you'll need to add a "Virtual" statement in the Screen section of xorg.conf. You'll notice I set it to 2048x1536 which is larger than I needed. On the 9500GT card a value of 1920x1200 worked, but the 210 required a bit more "real-estate" to map to 1920x1200. Here is the file that worked on my GeForce 8500GT-512P and works with my current GeForce 210 card (with the commented changes):

Section "Monitor"
Identifier "Configured Monitor"
Modeline "1920x1200" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -
HSync +Vsync
Modeline "1920x1080" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -
hsync +vsync
Modeline "1600x1200" 161.00 1600 1712 1880 2160 1200 1203 1207 1245 -
hsync +vsync
Modeline "1600x1024" 135.50 1600 1696 1864 2128 1024 1027 1037 1063 -
hsync +vsync
Modeline "1400x1050" 121.75 1400 1488 1632 1864 1050 1053 1057 1089 -
hsync +vsync
Modeline "1360x768" 84.75 1360 1432 1568 1776 768 771 781 798 -hsync
+vsync
Modeline "1152x864" 81.75 1152 1216 1336 1520 864 867 871 897 -hsync
+vsync
Modeline "1024x768" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync
+vsync
# Max size for Soyo Topaz S 24" monitor
Option "PreferredMode" "1920x1200"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
# For GF8500GT-512P
Depth 24
Virtual 1920 1200
# for GeForce 210
# Depth 32
# Virtual 2048 1536
#
Modes "1920x1200" "1920x1080" "1600x1200" "1600x1024" "1400x1050
" "1360x768" "1152x864" "1024x768"
EndSubSection
EndSection

Section "Device"
Identifier "Configured Video Device"
# For GF8500GT-512P
Option "Monitor-VGA2" "Configured Monitor"
# For GeForce 210
# Option "Monitor-VGA0" "Configured Monitor"
EndSection

Section "ServerFlags"
Option "DontZap" "True"
EndSection

geraldgrogan
March 27th, 2010, 08:29 AM
Sorry to post to this old thread, but after searching all day for an answer the very same issue with this same video card, I was guessing that others might be interested in what worked for me.

After a kernal update my video stopped working. I had my PC connected to my flat screen monitor via a vga cable, which apperently was causing the problem, The log file mentioned that it could not determine the monitor model number. Appearently, this card needs to be connected via a dvi cable in order to operate properly (or at all).

Once I connected this video card to the monitor using a dvi cable, and then rebooted, the high resolution started working perfectly. Just in case I am not the last person on Earth to upgrade to DVI, I urge everyone to upgrade to DVI cables ASAP.

I hope this helps.

HammerHed
March 29th, 2010, 05:52 PM
@geraldgrogan - Thanks so much I have been scratching my head about this issue for some weeks now and you have provided the rather obvious I guess solution. I switched to the DVI cable for my monitor and it now works perfectly, Nvidia driver can now see all the correct display settings from the monitor.

I now got the correct resolution and all the correct screen options etc.

;)