PDA

View Full Version : [ubuntu] Add/Remove missing, unable to run Synaptic!



Tholley
June 6th, 2009, 11:01 PM
I am running 9.04 and have been messing with different media players all day, but now when I went to add VLC, I notice my Add/Remove was missing, so then I went to Synaptic
Package Manager, and typed in my password, I get this message...

Failed to run /usr/sbin/synaptic as user root.

The underlying authorization mechanism (sudo) does not allow you to run this program. Contact the system administrator.

I rebooted, thinking it was a glitch, but still the same.

What in the world could I have done to mess this up?

HereInOz
June 6th, 2009, 11:18 PM
Can you try installing vlc from the command line

sudo apt-get install vlc

This will let you know whether it is Synaptic which is broken, or whether you are unable to run anything with root privilidges.

Tholley
June 6th, 2009, 11:23 PM
Nope... this is what I got...

terrell@terrell-bedroom:~$ sudo apt-get install vlc
[sudo] password for terrell:
terrell is not in the sudoers file. This incident will be reported.
terrell@terrell-bedroom:~$

oldos2er
June 6th, 2009, 11:35 PM
http://www.psychocats.net/ubuntu/sudo

Tholley
June 6th, 2009, 11:42 PM
Thanks Ann!
I printed that out and will give it a shot.

HereInOz
June 6th, 2009, 11:49 PM
It looks like you have somehow removed your ability to administer the system.

Clearly, someone must have the ability of administrator, at least through sudo, but if you now have no-one who has administrator capability, you could be in a little bit of strife.

It is always a good idea to set up a second user who can administer the system, just in case something like this happens.

I hope the tutorial to which Ann has pointed you will help.

Tholley
June 7th, 2009, 12:27 AM
Ok it worked! Not at first, but the second try doing the "adduser terrell admin" worked. It seems everything is back to normal. I was able to install VLC from Add/Remove and opening Synaptic seemed all good too.

Thanks guys!

I have no idea how I screwed it up in the first place.