PDA

View Full Version : [ubuntu] usb problems virutal box 2.2.4



burntresistor
June 4th, 2009, 07:33 PM
I just started trying to get Virtual box working and I can't seem to get the usb HD working, It detects that I have it connected to the computer in settings before I start VB. I unplug and replug the usb HD after I turn on VB. What else can I do to fix this I'm running VB in XP

mirons
June 4th, 2009, 08:16 PM
I had a problem wit usb on vbox, too, don't know if it's the same. vbox detected the device in devices menu, but they were disabled. It was a permissions issue, fixed adding a line in /etc/fstab
here is the line

none /proc/bus/usb usbfs devgid=112,devmode=664 0 0

BTW: devgid is the GrouID of group vboxusers

beameup
June 4th, 2009, 08:19 PM
Did you check the box in "Settings" > "USB" next to the drive?

See attached for an example. That worked with my TomTom. I have XP in a virtual machine.

WIGGMPk
June 4th, 2009, 08:59 PM
Make sure your user is part of the vboxusers group, add it if its not, than restart and it should work fine.


Adding the line to /etc/fstab should not be neccessary. But that would be my next step if your already part of the vboxusers group. I would check the group settings first though.

burntresistor
June 6th, 2009, 12:05 AM
I had a problem wit usb on vbox, too, don't know if it's the same. vbox detected the device in devices menu, but they were disabled. It was a permissions issue, fixed adding a line in /etc/fstab
here is the line

none /proc/bus/usb usbfs devgid=112,devmode=664 0 0

BTW: devgid is the GrouID of group vboxusers

What did you mean by groupID and how is it changed or checked to see if mine is right? the command didn't have permissions , also in usb settings all necessary usb boxes were checked

WIGGMPk
June 7th, 2009, 10:32 PM
What did you mean by groupID and how is it changed or checked to see if mine is right? the command didn't have permissions , also in usb settings all necessary usb boxes were checked

You shouldnt need to do this...

Have you checked to see if your user is part of the vboxusers group??

I had the same issue before and adding my user to the group resolved it.

doomsword2001
October 3rd, 2009, 11:36 PM
hey guys i have VB usb prob too.
i followed other guides which users repliy and say that works but i cant get it working.
1. my usb are not gray'ed out, they appear as normal.
2. i right click and enable the usb.
3. win xp detects usb, installs drivers.
4. then xp freezes until i disable usb again.

i have added my self in group, i have the usb unmounted and enabled in VB.
any ideas?
cant switch to vmware cause its kind of slow and i need xp for visual studio sto VB is my only solution :/

doomsword2001
October 4th, 2009, 12:15 AM
i have managed to get my printer working which was my main prob :)
my external hard disk is still not working :/ so its a hard disks prob i guess
so nvm