PDA

View Full Version : [ubuntu] What is a good program for ripping cd's to mp3



TheBootstrapKid
June 1st, 2009, 07:35 PM
right now i am using rhythmbox. it seems kinda slow.

dje
June 1st, 2009, 07:40 PM
you could try sound juicer, open a terminal (Applications >> Accessories >> Terminal) and run:

sudo apt-get install sound-juicer
Then open Applications >> Sound & Video >> Audio CD Extractor

dje

steeleyuk
June 1st, 2009, 07:41 PM
Sound Juicer usually works fine. Rhythmbox usually rips pretty well, and imports directly into your library as a plus.

Gazneth
June 1st, 2009, 07:42 PM
Maybe try soundjuicer, it works ok for me. My favorite ripping program is CDex which unfortunately is windows only.

gn2
June 1st, 2009, 07:45 PM
My favourite is Grip.

MrWES
June 1st, 2009, 08:15 PM
right now i am using rhythmbox. it seems kinda slow.

ABCDE -- command line, but solid and fast.

*********************************/abcde.html

Therion
June 1st, 2009, 08:19 PM
Just one more suggestion: GnomeBaker

It's in the repo, it's easy and it's gnome/gui based.

logos34
June 2nd, 2009, 06:03 AM
I would recommend you NOT to use sound-juicer, especially for mp3, as detailed here (https://help.ubuntu.com/community/CDRipping#MP3%20Encoding). Settings config is needlessly confusing (i.e. pipelines), and unless there's been an update, the gstreamer backend will screw up lame vbr output. A lot of people are blissfully unaware of the problems. (I've managed to fix mp3 vbr output--I think--only by reverting to an earlier gstreamer lame plugin, gstreamer0.10.5.2-plugins-ugly-multiverse).

Use rubyripper (esp. if you want secure rips), abcde or grip

laffinet
June 2nd, 2009, 06:12 AM
ABCDE -- command line, but solid and fast.

+1 for abcde

Don't let the fact that it's only command line and not GUI turn you away. Once you set it up properly (by editing/creating a config file) it's as simple as plopping in the CD, typing "abcde" in a terminal and Bob's your uncle.

A few minutes later you have your mp3s in a designated folder, nicely tagged to your liking. Simple, fast, reliable. Love it.

binbash
June 2nd, 2009, 10:09 AM
Sound Juicer is good for flac etc but not mp3s

billgoldberg
June 2nd, 2009, 11:02 AM
I always use RipperX.

Easy to use and fast.

MichaelSammels
June 2nd, 2009, 11:05 AM
I tend to use abcde

RichardG891
June 2nd, 2009, 11:25 AM
I use ruby ripper, same as logos34 - very slowwww though. Some people have managed to get Exact Audio Copy working under WINE.

sica07
June 2nd, 2009, 03:16 PM
+1 RipperX
Intuitive interface, easy to use and quite fast.

TheBootstrapKid
June 2nd, 2009, 04:07 PM
i installed GRIP. it is ripping to .ogg. How do i change it to mp3

sica07
June 2nd, 2009, 04:18 PM
Soundconverter (http://soundconverter.berlios.de/) it's all that you need.

gn2
June 2nd, 2009, 04:52 PM
i installed GRIP. it is ripping to .ogg. How do i change it to mp3


Config > Encode > Encoder, set to Lame, then in Options you can set the bitrate.

In Config > Rip you can set it to auto rip on insert and auto eject when finished.

steeleyuk
June 2nd, 2009, 05:01 PM
Soundconverter (http://soundconverter.berlios.de/) it's all that you need.

Sound Converter doesn't rip CDs. Its only... converts.

sica07
June 2nd, 2009, 05:18 PM
Sound Converter doesn't rip CDs. Its only... converts.
I know that. I just thought that: GRIP-rip to ogg && Soundconverter-converts to mp3. (I don't know if GRIP can rip in mp3 format. I never use it)

TheBootstrapKid
June 2nd, 2009, 05:24 PM
Config > Encode > Encoder, set to Lame, then in Options you can set the bitrate.

In Config > Rip you can set it to auto rip on insert and auto eject when finished.

I did this and now i'm getting the following warning:
Invalid encoder executable
check your encoder config, and ensure that it specifies the full path to the encoder executable.

oldos2er
June 2nd, 2009, 05:59 PM
I did this and now i'm getting the following warning:
Invalid encoder executable
check your encoder config, and ensure that it specifies the full path to the encoder executable.

Do you have lame installed?

gn2
June 2nd, 2009, 06:10 PM
Run this in a terminal to install Lame and the error should disappear.


sudo apt-get install lame

TheBootstrapKid
June 3rd, 2009, 09:21 PM
I have lame installed and i am still getting the same message.

the encoder is Lame

the encoder executable is Lame

the encoder commandline reads -h -b %b %w %m

the file extension is mp3

and the file format reads ~/ogg/%A/%d/%n.%x

what gives?

oldos2er
June 3rd, 2009, 10:11 PM
The encoder executable should be /usr/bin/lame

techstop
June 3rd, 2009, 10:38 PM
Here's a great tutorial on how to set up grip in our very own tutorial forum;

http://ubuntuforums.org/showthread.php?t=183125