PDA

View Full Version : [ubuntu] gimp toolbox/layers in way, can't see image



fluxlizard
May 27th, 2009, 02:36 PM
Hi all,
I hate the new default gimp layout where the toolbox and layers always stay above the image, because it blocks the menubar in the image window and blocks the image unless I move the boxes around constantly. Much easier to be able to click the appropriate box in the windows selector in the panel and choose what I want on top at the moment. Can anyone tell me where change the default behavior of the toolbox and layers box so they aren't forced to remain above the image I'm working on? Its driving me batty!
Thanks much!

The Cog
May 27th, 2009, 03:02 PM
I found the easiest thing was to configure my window manager so that double-clicking the title bar rolled the window up. At least then all you have to fight against is a title bar.

fluxlizard
May 27th, 2009, 04:16 PM
yeah- that would sort of work. There's a proper way to set it up in the preferences of gimp though- I had to do it last release, but can't remember how I did it and can't find the answer anywhere...

Bearly Able
May 27th, 2009, 04:23 PM
I'm having the same problem. I thought there was a way to change the settings in preferences, but if there is, I couldn't find it. I think I've spent more time looking than I have editing images! If I do find an answer, I'll post back.

mcduck
May 27th, 2009, 04:35 PM
In Gimp preferences , under Window Management, set the "Hint for the toolbox" and "Hint for other docks" to "Normal Window".

Bearly Able
May 27th, 2009, 05:04 PM
Thanks, mcduck, that does the trick. I'd looked at those options, but failed to understand what they did.

fluxlizard
May 28th, 2009, 01:16 PM
Ah yes, thank you very much indeed. I wasted a good hour of my life trying to figure that out by looking in the gimp and searching on the net.

I really wish the package maintainer would keep that setting normal by default. That's got to be bugging plenty of noobs to the gimp/linux if it bugs someone like me who has been using it for years...

DJ_Peng
September 12th, 2009, 01:47 PM
In Gimp preferences , under Window Management, set the "Hint for the toolbox" and "Hint for other docks" to "Normal Window".
Thank you, mcduck. That's bugged the living hell out of me every since I got the update. I can't begin to how nice it is to have those two windows out of the damned way.

/me makes a not that he owes mcduck a brew. :guitar: