View Full Version : [ubuntu] 8.10 - No wireless

May 10th, 2009, 09:27 PM

I have a Toshiba Satellite Pro A120-140. I couldn't install 9.04 due to a graphics problem, so I am trying to install and run 8.10.

It has installed fine, and everything appears to work, but I cannot get the wireless working correctly. The machine has an Atheros wireless card, and I am accessing the network as normal from my macbook. There is nothing like a mac-address block in effect, and the broadcast SSID option in my router settings is enabled. I am using the Netgear 54G wireless router, and WPA2-PSK security. Although, I have tried disabling security, but to no avail.

In System > Preferences > Network Connections, I see no entries, and adding one using the correct information for my router doesn't help. When I right-click on the NetworkManager Applet icon on the menu bar, both the "Enable Networking" and "Enable Wireless" entries are ticked. When I left click the same icon, nothing appears under "Wireless Networks". It looks like available wireless networks would appear here..

When I look at System > Administration > Hardware Drivers, it says "No proprietary drivers are in use on this system". It has a green light next to "Support for Atheros 802.11 wireless LAN cards.", so it appears to be activated and currently in use...

When I click on System > Administration > Network Tools, I get a list of network devices on the window that pops up; lo, eth0, wifi0 and ath0. wifi0 and ath0 are greyed out. wifi0 has no entry in the "IP Information" listbox, but it has records of packets and bytes that have been transmitted, recieved etc. ath0 DOES have an entry in the "IP Information" listbox, IPv6, an IPv6 address, but nothing in the transmitted and received entries.

ifconfig tells a very similar story to the Network Tools window. I suspect that I need to tell my atheros drivers to start looking at ath0, rather then wifi0, or something.

Any ideas?

Craig Marshall

Edit: For now, I have plugged an ethernet cable in and am apt-get upgrading. Of course, I will let you all know if this fixes anything, and if so, I will then feel silly.

May 10th, 2009, 10:22 PM
Please disregard this message. I was led to believe I had a G-enabled wireless card, and I haven't. After adjusting the router to allow 802.11b connections, it works.

Thanks anyway!