PDA

View Full Version : [ubuntu] A little confused with samba network behavior.



lannatwin
May 10th, 2009, 01:58 AM
I'm a bit of a noob, so please be gentle.

I'm networking two machines running 8.10 with samba. Netgear wireless router.

Machine 1 is on a wired connection. Machine 2 is wireless.

On machine 1 I can go to places/network and I see machine 2.

On machine 2 to see machine 1 I must go to places/network/windows network/workgroup/

Is this normal behaviour? In the past, I thought I could just go to places/network to see either machine.

I haven't made any modifications on either machine- other than setting up a share on the public folders.

Thank you for any assistance / explanation.

lannatwin
May 12th, 2009, 02:34 AM
What, nobody has any thoughts on this? I thought surely there would be some networking wizards out there that could tell me if something is amiss here.:confused:

klein de usa
May 14th, 2009, 03:56 AM
hi
im no networking wizard, but i believe the easiest way is to set up static ip's on both computers. ubuntu 8.10 has a problem with static ip addressing you can google out ubuntu 8.10 static ip and you should be able to find a good guide.


creating a share in nautilus works well for me
did you set a samba password ?

open up network places and in the adress bar at the top put smb://static ip addres/folder you shared

when it asks for a password put your user password in

theozzlives
May 14th, 2009, 04:00 AM
edit your smb.conf as root and make sure the workgroup=WORKGROUP line is the same on both computers

klein de usa
May 14th, 2009, 04:12 AM
hi
this is the guide i used to change ubuntu 8.10 to a static ip http://www.ubuntugeek.com/how-to-set-a-static-ip-address-in-ubuntu-810-intrepid-ibex.html

lannatwin
May 14th, 2009, 08:13 AM
Thanks everybody. I'll gave that a try.