PDA

View Full Version : [all variants] a pre-configured disk to another pc



sganaway
May 9th, 2009, 08:57 PM
Hello everybody,
i've installed ubuntu netbook 9.04 on my desktop pc, and later i've take the harddisk and i've put it in another pc (more older than first).
The boot is ok, but the problems born when i try to change the user: a message say that the X crash for three time, because there is a problem with GDM or with X windows.

My first think is about the two different configurations of the machines.

there is a solution that avoid me to reinstall the system?...

(PS:the first user don't need a password!i think that this is the reason that i can enter in the system)

upchucky
May 9th, 2009, 09:12 PM
Linux is custom built for the machine it is installed on, the only way to install on one machine and then put the drive into another machine is for both machines to be exactly the same.

if linux was not designed this way then it would be a very huge bloated operating system, which would be very slow.

any user, first or not only needs a password if passwords are set up, and every user will need superuser password to be able to do administration stuff.

cariboo907
May 9th, 2009, 09:29 PM
Do you have the correct video drivers installed for the computer the drive is mounted in? I would suggest backing up /etc/X11/xorg.conf then editing out the driver for the origional installation, so it looks something like this:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection



Then restart x and set up the proper video driver

sganaway
May 10th, 2009, 08:03 PM
thanks everybody!
my xorg.conf is ok!
i'm thinking that maybe i must reinstall the gdm... it's better that reinstall entire the system, but i'm a bit scared because my hardware is a bit ancient!

what do you think?...there is a better way?

sganaway
May 10th, 2009, 08:27 PM
WAIT...It's ok! (thanks cariboo907 (http://ubuntuforums.org/member.php?u=77104))
I forgot to put the "DefaultDepth 24" line! #-o

But can i have other configuration problems (for my transfer-disk action)?

for example: i haven't the splash screen picture (it's not a problem, but i'm afraid that this hide some big problem!)