View Full Version : [ubuntu] Jaunty kernel .28 fails to load but .27 works

May 6th, 2009, 03:39 AM
I have a Emachine D620 that I had$ dual booting to Intrepid on a usb hard drive and after I did the upgrade to Jaunty I can not load the .28 kernel. If I select the .27 kernel it works. I have tried everything I can think of or find in other threads that have been suggested and nothing works. I have added rootdelay up to 300 and about 10 different addtions to the grub. Any help oout there or insight when this will be fixed? I checked Launchpad and I can see a number of reports of this bug.

On the positive side the .27 kernel had my Atheros wireless up and running out of the box, which was a first for me.

May 6th, 2009, 03:49 AM
Can you purge 2.6.28-11, and then reinstall it, to see if it makes a different. the kernel you want to remove is linux-image-2.6.28-11-generic

May 6th, 2009, 03:03 PM
I removed the kernel via synaptic and reinstalled, still no joy. Since I didnt use the purge command in a terminal, I am wondering if the removal was not as complete a removal task as the purge? If so what is the correct syntext to the purge command in the terminal?

May 6th, 2009, 09:45 PM
did you try boot the live cd or alternate cd of jaunty ? try it, and tell me, perhaps you have the same bug as mine :


May 7th, 2009, 01:05 AM
I haven't downloaded the the live cd yet. I will tonight and report back. I read through the launchpad report and the problem seems similar. I did notice that none listed the "could not locate the hdd and gave up, dropping to shell". warning that I am getting.

May 7th, 2009, 07:27 PM
Thanks for posting the link to launchpad. Some of it looks very similar to the problems I've found - http://ubuntuforums.org/showthread.php?t=1145427

May 7th, 2009, 09:28 PM
Same here with me: http://ubuntuforums.org/showthread.php?p=7230485#post7230485

May 8th, 2009, 03:05 AM
Just tried the live cd and I can boot to it. I did a fresh install and I get the same error on boot.

June 4th, 2009, 02:14 AM
I recently found a thread on a different forum and the temporary fix was to do a "modprobe usb-storage" at the prompt and let it run for a few seconds (until it reports back with a few lines), then type "exit" and boot will continue. This works, but I have to do it at every restart. I need to know how to get this applied automatically at startup.

June 4th, 2009, 11:41 PM
Just installed the new kernel from the Jaunty proposed repository and boot now executes with no issues.:guitar: