PDA

View Full Version : [ubuntu] How do I install java?



Rigorous
May 6th, 2009, 12:34 AM
I have been trying to install java by reading the instructions on their page and when i typed su into the terminal i get an error so I found out you have to use sudo apt-get install packagename, well I put the name of the file exactly and said it couldn't find package?

Thanks for the help!

Oh yes, I would also like to thank ubuntu for the free CD :)

aysiu
May 6th, 2009, 12:35 AM
Read this:
http://www.psychocats.net/ubuntu/installingsoftware

The package you want to install is called sun-java6-jre

raymondh
May 6th, 2009, 12:37 AM
Why not just use synaptic and look/search for sun-java. I think it's sun-java6

system>administration>synaptic

Enjoy

Rigorous
May 6th, 2009, 12:45 AM
Read this:
http://www.psychocats.net/ubuntu/installingsoftware

The package you want to install is called sun-java6-jre

Ok I went to add/remove and installed java... but when I go to play a java game it says I do not have java?

Rigorous
May 6th, 2009, 12:52 AM
Why not just use synaptic and look/search for sun-java. I think it's sun-java6

system>administration>synaptic

Enjoy

I tried that and installed it and still when I go to play a game java is not recognized? Im using firefox and using ubuntu 8.10.

presence1960
May 6th, 2009, 01:00 AM
I tried that and installed it and still when I go to play a game java is not recognized? Im using firefox and using ubuntu 8.10.

Try installing this java plug in for firefox if you are using 64 bit : http://ubuntuforums.org/showpost.php?p=6791349&postcount=59

Rigorous
May 6th, 2009, 01:02 AM
Try installing this java plug in for firefox if you are using 64 bit : http://ubuntuforums.org/showpost.php?p=6791349&postcount=59

I have 32 bit.

aysiu
May 6th, 2009, 01:11 AM
Ok I went to add/remove and installed java... but when I go to play a java game it says I do not have java?
It may be something as simple as exiting Firefox and then starting it again.

raymondh
May 6th, 2009, 01:27 AM
It may be something as simple as exiting Firefox and then starting it again.

Aren't we able to see if java is among the plug-ins in firefox? I think (to check) .... type in the address bar


about:plugins

and then scroll if java is enabled. If not, then java has not been installed or is improperly installed ...

Let me see mine ...hmmmm ... yup, java enabled thru ICED TEA ... note I'm using right now a derivative of Hardy (called gOS)

Raymond

Sef
May 6th, 2009, 01:28 AM
Quote:
Originally Posted by presence1960 http://ubuntuforums.org/images/buttons/viewpost.gif (http://ubuntuforums.org/showthread.php?p=7221398#post7221398)
Try installing this java plug in for firefox if you are using 64 bit : http://ubuntuforums.org/showpost.php...9&postcount=59 (http://ubuntuforums.org/showpost.php?p=6791349&postcount=59)

I have 32 bit.

Make sure you have the 32-bit plug in installed. It is in add/remove too.

raymondh
May 6th, 2009, 01:31 AM
can't seem to disable smilies...sorry

about:plugins

Rigorous
May 6th, 2009, 02:05 AM
Make sure you have the 32-bit plug in installed. It is in add/remove too.

Thank you very much!!! It works :)

ssdt
May 6th, 2009, 02:25 AM
Download the .deb from their site and use that. That could work, I think.

Miljet
May 6th, 2009, 02:38 AM
Download the .deb from their site and use that. That could work, I think.

Bad idea! The instructions on the Sun site are not written for Ubuntu and are impossible for newbies to follow.

RealPSL
May 6th, 2009, 03:23 AM
Rigorous,

If this is for your web browser (Firefox) you need to install sun-java6-plugin.