PDA

View Full Version : [ubuntu] nvidia driver - xorg



alkatron
May 1st, 2009, 01:43 PM
I've installed Hardy 64 bit in a different partition of the same computer which Hardy 32 bit is installed on.
my graphic card is:

*-display
description: VGA compatible controller
product: GeForce 8600 GT
vendor: nVidia Corporation
physical id: 0
bus info: pci@0000:05:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list
configuration: driver=nvidia latency=0 module=nvidia


As in the 32 bit version, I Installed NVIDIA drivers as said in
http://www.nvidia.com/object/linux_display_amd64_180.51.html


CTRL+ALT+F1
gdm stop
sh NVIDIA-Linux-x86_64-180.51-pkg2.run
gdm start


and everything is ok compiz cube included......and so i copied xorg.conf to xorg.conf.alk

The problem start when i reboot....it always boot in low res mode and reset xorg.conf to a vesa driver....
Then if I


CTRL+ALT+F1
gdm stop
cp xorg.conf.alk xorg.conf
gdm start


again...everything is ok.

But i have to do it everytime i boot.....
Where is the problem......?

this is both xorg.conf

Xorg.conf.alk (OK-to copy over xorg.conf every time I reboot after low-res start)


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Apr 17 00:40:10 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


xorg.conf....that i find everytime I reboot and have to substitute with xorg.conf.alk


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Apr 17 00:40:10 PDT 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
Screen 0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Virtual 640 480
Depth 24
Modes "640x480@60"
EndSubSection
EndSection


In hardy 32 bit i have no problem using the same procedure

Thanks

Alkatron