PDA

View Full Version : [ubuntu] 9.04 pon dsl-provider problem



ehsun7b
May 1st, 2009, 04:38 AM
I've recently upgraded my ubuntu 8.10 to 9.04 using update-manager -d command.
Now I can not connect to the ADSL internet by sudo pon dsl-provider command, but when I use the pppoeconf to re-config my connection, in the last step it asks my if I want to connect now, and I choose yes, after that the connection works! But the nest time I use pon it doesn't work again and I have to use pppoeconf again!!!

ehsun7b
May 1st, 2009, 07:20 AM
Has anybody experienced same problem?

ehsun7b
May 1st, 2009, 11:44 AM
I'm still waiting to get a solution from you! :popcorn:

gredorian
May 1st, 2009, 05:47 PM
I have a similar problem. For me it just doesn't connect at boot anymore as it did with Intrepid. I use "pon dsl-provider" and it sometimes connects but others I need to use pppoeconf all over again. Pretty annoying.

Xfirebg
May 2nd, 2009, 12:19 PM
try:
sudo poff dsl-provider

after that

sudo pon dsl-provider

ehsun7b
May 2nd, 2009, 05:33 PM
I've already tried! I doesn't help

ehsun7b
May 2nd, 2009, 05:36 PM
try:
sudo poff dsl-provider
sudo pon dsl-provider


after enetring
sudo pon dsl-provider
I receive this:

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5

golusweet
May 2nd, 2009, 05:44 PM
Configure your modem to connect to the internet.

You don't need to use all this then.:)

ehsun7b
May 2nd, 2009, 07:54 PM
Configure your modem to connect to the internet.

You don't need to use all this then.:)

How?

H.K.Murmu
May 2nd, 2009, 08:26 PM
I have the same problem and always use pppoeconf to connect internet. But now I am able to connect through network manager applet no need to open a terminal.

To connect through ADSL modem you have to configure your modem device by self or take it to your service provider. Once configured then follow the steps
1:-system----adminstration------user and groups
2:-In user setting select user-----properties---check the box "connect to internet using modem" and "connect to wireless and ethernet networks" then close
3:- open network manager applet from panel under DSL ---ADD---Edit DSL connection-----in tab DSL provide internet userid and password and under tab IPv4 setting select "automatic pppoe" and then close(perhaps require restart system not sure)
4:-In pannel left click and click the radio button
5-now you are connected to internet through Network manager Applet

darkhole
May 3rd, 2009, 04:52 PM
after enetring
sudo pon dsl-provider
I receive this:

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5



Seems like this a bug, really ugly bug:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/355826

So, network manager is the problem...

ehsun7b
May 3rd, 2009, 05:01 PM
I have the same problem and always use pppoeconf to connect internet. But now I am able to connect through network manager applet no need to open a terminal.

To connect through ADSL modem you have to configure your modem device by self or take it to your service provider. Once configured then follow the steps
1:-system----adminstration------user and groups
2:-In user setting select user-----properties---check the box "connect to internet using modem" and "connect to wireless and ethernet networks" then close
3:- open network manager applet from panel under DSL ---ADD---Edit DSL connection-----in tab DSL provide internet userid and password and under tab IPv4 setting select "automatic pppoe" and then close(perhaps require restart system not sure)
4:-In pannel left click and click the radio button
5-now you are connected to internet through Network manager Applet

I 've made a DSL connection according to the instruction, but now whene I left click on the Network-manager icon in notification area, it has some disabled items and VPN sub menu :(:(:(

ayonkhan
May 3rd, 2009, 05:52 PM
1:-system----adminstration------user and groups
2:-In user setting select user-----properties---check the box "connect to internet using modem" and "connect to wireless and ethernet networks" then close

Is this really mandatory?? I mean, am I bound to do it? I haven't done it on Intrepid and didn't faced any problem though.

mcwest79
May 13th, 2009, 01:48 PM
I have the same problem and always use pppoeconf to connect internet. But now I am able to connect through network manager applet no need to open a terminal.

To connect through ADSL modem you have to configure your modem device by self or take it to your service provider. Once configured then follow the steps
1:-system----adminstration------user and groups
2:-In user setting select user-----properties---check the box "connect to internet using modem" and "connect to wireless and ethernet networks" then close
3:- open network manager applet from panel under DSL ---ADD---Edit DSL connection-----in tab DSL provide internet userid and password and under tab IPv4 setting select "automatic pppoe" and then close(perhaps require restart system not sure)
4:-In pannel left click and click the radio button
5-now you are connected to internet through Network manager Applet


Thanks for these tips! I had upgraded 8.10 to 9.04 with the System Update tool and had been unable to connect using "pon dsl-provider" since. I still am not seeing any options to connect via the network applet on the Panel, but "pon" works, so good enough!

navblitz
May 14th, 2009, 03:58 PM
Try this, it has to work

1. At Konsole, type

sudo pppoeconf

Then you will be asked for the username and password which has been provided to you by the ISP.

Then keep on selecting "Yes" for the options that follow.

The last but one option(i think) will ask you if you want to auto connect at boot time( this is important).

Otherwiase you will have to type "pon dsl-provider" to start and "poff" to stop the connection.

pon/poff doesn't work for me. It says i have to belong to some "dip" users or something. Any idea what it is??
So, i always auto connect.

This should do it for you.

legatoloco
May 23rd, 2009, 11:18 AM
I'm having the same problem, as in, can't see the ppp connection from the network manager applet.
but i was also having the problem where i always need to pppoeconf before connecting, because just starting pon was returning that the network is down.
it turned out at the end that every time i was plugging in my modem (an iburst modem) the interface was not going up automatically (was working correctly before 9.04)
so if this is your problem, all you have to do is:
sudo ifconfig xxx up
where xxx is your device name (eth, wlan, ib, something)
just just after you run pppoeconf and see it working, what devices are up (ifconfig) and check again after a restart, you will probably see a missing device.
i'm also having this problem with the wireless, which i have to bring up manually everytime i switch it on (hardware switch on the laptop) which was also working before 9.04.

FishyFantasy
May 23rd, 2009, 03:50 PM
I'm having the same problem too. But! It doesn't work in both method "pon dsl-provider" and configuring network manager. I'm sure both my username and password is correctly entered. Anyone can help?

chinesedragon
July 30th, 2009, 02:24 PM
I have the same problem!!!!Help Please!!!!!

Ian Clark
August 2nd, 2009, 07:04 AM
I don't think this is specific to 9.04. I'm on Intrepid and strangely, "pon dsl-provider" simply doesn't work anymore (as of 2009/07/26). No error message or anything. To get the connection running I have to restart the computer - annoying!

moboticdes
January 2nd, 2011, 10:25 AM
I have a solution for all this thread.
If your modem is setup as bridged+routed mode it means you can both connect directly to the ISP provider with pppoe or otherwise connect to the router only (as someone suggested before).

To connect only to the router and avoid the pppoe connection you must edit
/etc/sysctl.conf which must contain the following values (uncomment values or add where needed)



net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_window_scaling = 0
net.ipv4.tcp_ecn= 0

This will avoid all problems you described.